"Harm Your Computer" Message

I’m running the latest stable release of Brave as of this writing (1.2.43). In prior versions of Brave I could download DMG files just fine. Now whenever I do, a message appears and informs me that downloading that type of file (a DMG) may “harm my computer.” How do I disable this and make it such that I can simply download DMG files the way I recently used to, without having to click an extra button to allow the download to commence? Thank you.

@screenwriter,
Interesting that I haven’t seen this alert myself yet – would you mind sharing a screenshot of what the alert looks like when its displayed on your end?

Thanks for looking into it!

@screenwriter,
Hmm, so I don’t seem to be getting the same warning when I try to download .dmg files. I even went ahead and downloaded the same .dmg file you tried and it worked without any warning. Do you have any flags enabled by chance in brave://flags?

Also, can you tell me what OS version you’re using?

I’m using MacOS Mojave 10.14.6 and I have the following flags enabled:
Accelerated 2D canvas
Partial swap
Latest stable JavaScript features
Hardware-accelerated video decode
Hardware-accelerated video encode
Threaded scrolling
All other flags are marked as Default or else Disabled.

Not sure if this would be helpful, but the closest thing to an answer I’ve found so far was on a Vivaldi forum - apparently hexediting does the trick?

https://forum.vivaldi.net/topic/11827/any-way-to-disable-the-this-type-of-file-can-harm-your-computer-warning

Although as a not-so-power-user, I’m not sure how I’d start on that in Brave. Thoughts? Just started happening recently, and if you and I are on the same version of Brave, I have no idea why it’s happening just for me.

Also found this - a way to disable it through the command line?

1 Like

@screenwriter,
Do you have the browser set to ask each time where you want to download a file or is it toggled off? If so, can you try enabling it? I’m curious to see what this does.

I’ve always had it set to not ask. When I enable that setting, it asks me where I’d like to save the file and then downloads it without a problem. But I’ve always been able to toggle that to off and it simply saves to my default location without any hullaballoo. This is a new behavior, and unwelcome.

For what it’s worth, I just tried downloading the same file in Chrome 79.0.3945.130 and it downloaded to my default location with no such error message. Curiouser and curiouser…

Here’s something. I found that if I toggle off Safe Browsing, the message no longer appears when I download DMGs and I can apparently download all files just fine. I usually browse with Safe Browsing on, so I’m not sure if it’s worth the trade-off. Still, this seemed to do the trick. It would be ideal if I could keep Safe Browsing on and not have the “this file may harm your computer” dialog appear when I download files.

1 Like

And even stranger: I just re-enabled Safe Browsing and tried to download the same DMG and now the “harm your computer” dialog doesn’t appear anymore. Maybe some sort of bug tied to that setting? Will report any further odd behaviors.

1 Like

@screenwriter,
Apologies for the late reply – have been on PTO the last week. Thank you for your patience and for your reports.

For what it’s worth, you should definitely always have Safe browsing on, as it houses many difference security features in the browser that help keep you safe online. The issue fixing itself by toggling Safe browsing on/off though is, as you said, quite curious.

I’m going to keep this thread open in the event that you encounter the behavior again so that you can let me know.

Version 1.4.95
Windows 10

I’m quite new to brave and found this thread because I was having the same issue, and it was driving me mad.
Toggling safe browsing on and off seems to have fixed it.