GTK theme does not follow system or Brave colors settings

Description of the issue:
Brave has no method to set dark/light mode to match the system settings in Linux even though setting theme to GTK should do that and it works in Chromium.
The only way to switch between light and dark is to go into settings and manually switch between light and dark when using classic theme.

How can this issue be reproduced?

  1. Set Brave theme to GTK.
  2. Click the “Dark Style” button in the Gnome quick settings menu.
  3. Nothing happens in Brave (stuck in light theme)

Expected result:
Brave should switch between Dark and Light appearance. See below how Chromium reacts vs Brave:

Brave Version( check About Brave):

Additional Information:
Please give Linux some love. Brave always feels like a work in progress on Linux. For a while ad-blocking didn’t even work as well as in Windows and some sites wouldn’t load properly.

If you cannot get light/dark to match the system like Chromium, at least put a toggle on the address bar so we don’t have to dig through settings to go back and forth.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.