Got a new computer, uphold will not connect

Briefly describe your issue:

I’ve had Brave for two years and use Uphold to hold my Brave BAT. I was using a Mac. I just got a PC, installed Brave and logged in. Tried to connect my Uphold account and keep getting the error message:

“Your request is still being processed, please wait. Sorry there was a problem processing your request, please try again.” With a red button that says “Try Again”.

I keep clicking it, same thing over and over. I closed and re-opened, logged in and out, etc. It will not connect.

What Operating System and Brave version are you using? (Menu --> About Brave)

Brave is up to date
Version 1.57.57 Chromium: 116.0.5845.163 (Official Build) (64-bit)

Who is your verified custodian? (Uphold/Gemini/bitFlyer)


Are you in a supported region? (see here for list of supported regions)


1 Like

I’ll tag @saoiray @mattches to help.

Just out of curiosity though, since this is a new computer you won’t have any vBAT so if you reset the brave rewards profile, and retry connecting what happens? Does it fix it?

Hello! We’re looking into the matter and hope to have it resolved soon. Sorry for the inconvenience.

1 Like

The same is happening here in Brazil. Initially this problem appeared sporadically on my smartphone. Last week I installed it on my PC and since then I am unable to activate my wallet on Uphold, the only option available for my region. Kindly check what is going on. grateful

We’re aware of the issue and hope to have a solution here shortly. Thanks again for your patience!

1 Like

This should now be resolved. Thanks!

1 Like

Thank you so much!! Yes it works now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.