Google Meet not working properly after upgrading to BigSur

Camera is stuck in “starting mode” and no audio is picked up by the speaker
How can this issue be reproduced?

  1. Upgrade a Mac from Catalina to Big Sur
  2. Try joining a Meet call

Expected result:
On the start screen, you should see “camera is starting”, when you join the call, you should not get any audio.

Brave Version( check About Brave):
Version 1.25.72 Chromium: 91.0.4472.101 (Official Build) (x86_64)

Additional Information:
I just upgraded to BigSur over the weekend and joining my when first Meet call with it this morning on Brave I was unable to use my camera nor get audio; other participants could hear me though.

I have gone through all the normal checklist to ensure it’s a Brave issue, from trying other browsers to ensuring that the Hangout extension is on, and that Brave has permissions to both the camera and microphone.

I also went ahead to install Brave-beta and everything works well on the beta browser too…just my main Brave browser. I don’t plan on using the beta browser, so it’ll be nice to have this fixed.

Anyone with ideas on what to do to fix this?

You could try with a fresh user profile.

@Rethanis So I followed the steps in the shared post and everything works. Does this mean I have to delete my current profile? How does this affect information linked with my current profile? Is there anyway to “refresh” the profile or get it to work without using a new profile?


You could try clearing all browsing data of your current user profile.

brave://settings/clearBrowserData => Advanced => Time range: All time => Check all options => Clear data

Note 1: This will log you out of all websites, make sure you know your logging credentials for websites you log into!

Note 2: Clearing the browsing data for “Site and Shields Settings” resets global Shields settings. If you are not using the default global Shields settings, you’ll have to re-adjust the settings at brave://settings/shields after you clear the browsing data.

1 Like

This worked. Thanks!


Great work @Rethanis :slight_smile: