Google Meet Camera shows input on my screen but other user cannot see or hear me

When I launch a google meet window, I can see the input from the camera and hear myself from the microphone, however, the party I’m meeting with cannot hear or see me. When I switch to Safari, it works flawlessly. I’ve allowed permanent camera and microphone access in Brave’s settings for Google Meet and in the address bar lock icon.

How can this issue be reproduced?

  1. Launch a Google Meet window
  2. Allow Camera and Microphone Settings
  3. Join Meeting

Expected result:

Other user should be able to see and hear me

Brave Version:

Version 1.19.86 Chromium: 88.0.4324.96 (Official Build) (arm64)

1 Like

I have same issue.

Version 1.19.86 Chromium: 88.0.4324.96 (Official Build) (x86_64 translated)

@dmlw,
First, can you check and ensure that Autoplay is not blocked on Google Meet? Additionally, please ensure that the Hangouts extension is enabled in Settings --> Extensions?

Hi, thanks for taking a look at this thread. Autoplay is allowed and Hangouts is enabled.

1 Like

@dmlw,
Thanks for the confirmation. Can you try opening your Shields panel on meet.google.com and changing the Fingerprinting option to Allow all fingerprinting? Let the page refresh and see if this changes the results. Also, do you have any extensions installed in the browser at this time?

It’s pretty strange since, on your end, it seems to appear as though everything is working without issue, but for everyone else on the call with you it’s not. Are you certain there isn’t a system setting on your mac that may be causing the issue?

Hi there, allowed fingerprinting and did another test and it seems to be working but I definitely don’t want to leave that allowed if at all possible. Weird because, as I mentioned, Safari works just fine so I don’t think it’s a computer setting.

It seems like instant meetings are fine but creating a meeting for later causes issues. It’s seeming more and more like a Google issue. I’ll keep testing!

Update: Zoom installed an audio device that was taking over upon launching meetings. Could be messing with both the camera and the audio device. I’ve uninstalled the zoom app and audio device and will test again.

1 Like

@dmlw,
Thank you for the update! Please let us know what you find out.

I’ve found a thread that suggests this is an issue with M1 Macbooks and Google Meet, and not Brave. I followed the advice to disable IPv6 on my Ethernet Adaptor and it worked. It seems connecting over WiFi isn’t an issue.

1 Like

Great detective work – thank you for letting us know.

1 Like

Hey, chiming in since I have the same annoying problem with seeing myself in the external camera but video meet participant can’t see me (they only see the avatar).

I have a MacBook Pro (16-inch, 2019)

The video options DO work in Chrome and Firefox which tells me that the issue is in the Browser and not in the hardware. All options are enabled.

I’ll try to All Fingerprinting and report back if that’s the case although I had the shields down for those pages. The problem started in the last week (2021/01/22).

Brave version:
Version 1.19.86 Chromium: 88.0.4324.96 (Official Build) (x86_64)

2 Likes

I have the same issue after updating to the version mentioned: I can see my camera but others in a Meet don’t.
I also have it in Chrome which has the same Chromium version 88.0.4324.96.
Safari works fine.

So after downgrading Brave to the previous version: 1.18.78 Chromium: 87.0.4280.141 others can see me again. So it will keep working until I restart and the latest version will be applied since it auto updates.

You can download the older version from here: https://github.com/brave/brave-browser/releases/tag/v1.18.78

Update: The camera still doesn’t work on MacOS even with fingerprinting on all. It doesn’t work with built-in MacBook camera or external.

As @nelisone mentioned, it seems to be the Brave version issue.

1 Like

Same problem and Brave does the same in Jitsi Meet, so it’s definitely something broken by the latest update. Before it worked fine, and I don’t recall needing a Hangouts extension.

New Version was introduced early this week but the problem still persist. Anyone here made it work?

Version:
Version 1.19.88 Chromium: 88.0.4324.96 (Official Build) (x86_64)

I suspect he problem is in combination/due to Chromium version 88.0.4324.96 since the problem also occurs with Chrome with the same Chromium version.

With new version of Brave the problem have been resolved!

Ver:
Version 1.19.92 Chromium: 88.0.4324.152 (Official Build) (x86_64)

1 Like