Google image search returning to the google.com search bar when "closing" an image

Description of the issue: When I search for anything and go to the images tab, then click an image to enlarge it on the right side of the window, instead of simply closing the side bar and widening the image search view, it goes simply to google.com and shows me the search bar. Just started today. Have tried incognito mode and restarting my PC.

Exact URL of the website in question: N/A, searching for anything using Google (e.g. a type of plant, a model of car, a person, etc.) and going to images, and selecting any image and then closing it with the X in the top left of the image, causes the issue.

Did the issue present with [default Shields settings]? (yes/no) Yes

Does the site function as expected when Shields are turned off? Yes

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no): Yes, standard ad/tracker blocking, HTTPS upgrading on, script blocking off, standard fingerprinting blocking, all cookies allowed. Disabling ad/tracker blocking seems to fix it, though I’m not sure why, as this just started today.

Does the site work as expected when using Chrome? Yes

Brave version (check About Brave): 1.38.109

2 Likes

exact same problem. Just noticed it today.

Really strange function, closing the image = returning to google home, is this being worked on?

Same problem here, glad it’s not just me!

@fsendventd ,

Probably related issue:

Tabs in the loaded page is not working - #8 by highwind85

Same problem here it’s so annoying hope get fix soon

Wanted to add to this that disabling AMP redirecting also seems to fix it, as a temporary workaround. That’s likely where the problem is, as suggested by @289wk .

Hi

@fsendventd Try this.

Open brave://settings/help and update browser to 1.38.117