Brave Image Search Not Loading Images

Good Afternoon,

I have an issue with searching images within the browser, not any errors with images on websites. Homepage is intact, it is only when using the images tab after a search. This is exclusive to the laptop I am currently using and not my desktop. Brave shields are not affecting the outcome and I have done an uninstall and reinstall. I am using version brave version 1.59.124 on a windows 11 laptop.

Has anyone else ran into this issue and found a solution?

Thank you.

@joshMMill I just tested and don’t have the issue. What you’re showing in the picture is how the page would appear if you have Block Scripts enabled. This would be a Shields setting, except you mentioned even turning it off has no impact, right? But would you happen to have any other extensions installed? If so, try with a private window or attempt to disable them. One of those could be doing the same thing.

I only have two extensions:

  1. Google Docs Offline
  2. Office - Enable Copy and Paste

I tried disabling both the extensions and the shields and it had no impact in a regular window and on the private window unfortunately.

Would there be a dedicated part of the settings for blocking scripts?

It’s in Shields. One is from the site specific portion of the Shields widget, the lion icon on your bar.


The global setting is found at brave://settings/shields


But with Shields off, as it appears in your second screenshot in the post I’m replying to, it shouldn’t be this as an issue.

Let me also have you try some of the following:

  • Create a new browser profile and test if it happens there. (Hamburger Menu image → More Tools → Add new profile)

  • Check brave://flags, did you change anything?

  • Assuming above two somehow don’t make a difference: does this also happen if you were to try to download Brave Beta or Brave Nightly?


Changing the shield settings did not affect the issue however making and using a different profile did work.

Would there be an additional setting that could be causing it on my current profile? The same profile that is having the issue is synced to a different machine that is not having that issue.

At least I know I can look for images in a different profile now.

Additionally I am not using any beta builds or nightly.

Thank you,


Hello, I’m having the same problem. I have read several threads stating the same problem and none of them have been resolved. I have a 64-bit windows laptop but Brave image results works fine on my android phone.

I have tried:

  1. disable block scripts in both Brave Shields & Global
  2. uninstalled all extensions
  3. cleared all browser history
  4. uninstalled/reinstalled Brave
  5. Java script enabled

Please help bc I used images a lot in my studies and I really don’t want to switch to another browser, thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.