Google Calendar misbehaving and kicking me out of page

When I am using Google Calendar in Brave and I create a new meeting slot, it works OK, but if I go back to edit the title or time of the event and click Save, the page refreshes automatically and sends me to the edit screen for a completely different and random meeting sometime in the future months. It has been doing this ever since I downloaded Brave about a month ago. I just click out of the event and search for the correct week and sometimes after a few tries I manage to edit the event I wanted to edit, but it’s still a hassle and I forget what edits I wanted to make in the first place.

I went to reproduce the problem just now so I can describe it here, but it did something different today. I created an event, went to edit it, and I don’t really know how to describe this, but it’s like I get kicked out of the page entirely and get what I would see if it was a New Tab page, which is empty address field and nothing on the screen. It kicks me out of Google Calendar instantly when I try to edit so I can’t say there’s any indication of what’s going on that results in me getting kicked out of the page.

Brave Shields are down for my Google Calendar as I know that can cause sites to misbehave. Browser extensions may be the culprit too, so here is a non-exhaustive list of some of the browser extensions I am using: LastPass, Ghostery, No History, AdBlock, I don’t care about cookies, Cookie AutoDelete (that one is installed but not active).

I am on Brave Version 1.11.97 Chromium: 84.0.4147.89 (Official Build) (64-bit)

An unrelated issue occurred as well when I went to check what Brave version I have. Brave tried to download an update and the following error message was displayed:

“An error occurred while checking for updates: The installer failed to uncompress archive. Please download Brave again. (error code 7: 0x80040902: 42 – system level).”

Great browser otherwise but really hoping to get some help with these issues from the devs.

I would rule out any of those extenstions, especially Ghostery and I don’t care about cookies. Can you test in private mode (no extensions installed)

1 Like

Yup, seems to work in private mode.

then back to normal mode and disable all extension then enable them one by one till you get which extension make the issue

hope that help and have a nice day

1 Like

Ok done, I think it was Ghostery causing the issue.

1 Like

congratulation well done and have a nice day :slight_smile:

Oops sorry, I think it wasn’t Ghostery but Cookie AutoDelete causing the issue, I can confirm with more certainty as I’ve now had time to do more rigorous testing on several devices

1 Like

well done nice work make :slight_smile: