Gmail Search Function in Brave Trouble

Description of the issue:
My sessions with in Brave, after successfully - every time - using https://mail.google.com/mail/u/0/#inbox - all works

EXCEPT FOR: the search in mail function.

It always finds - nothing

Exact URL of the website in question:
https://mail.google.com/mail/u/0/#inbox
Did the issue present with [default Shields settings] (yes/no)
yes
Does the site function as expected when Shields are turned off?
YES! btw, instructions and guidance in this form solved it for me. Nicely done folks.
https://tiny.one/AaronsStory - you’d make him proud too!
Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
Unknown
Does the site work as expected when using Chrome?
yes
Brave version (check About Brave):

Release Notes v1.44.112 (Oct 12th, 2022)

Hello @Traacker

Thanks for bringing this to our attention and sorry to hear you’re having trouble with Brave. Please try to open a new page using private mode or guest mode.

You can open a Guest Window by going to Main menu --> Open Guest window.

If that works, it could be related to an extension interfering with your profile, please try removing your extensions to see if it works properly. To Remove an Extension:

  1. On your computer, open Brave.
  2. At the top right, click Menu icon --> More tools --> Extensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Or

  1. On your computer, open Brave.
  2. On your extensions toolbar, right-click the extension you would like to remove.
  3. Select Remove from Brave… from the context menu.

Let me know if that works and have a nice day!