Fonts too large on KDE Desktop

Fonts (site as well as the UI) are too large: I have noticed all websites appear to have over sized fonts in Brave. Things look okay if I manually reduce the fontsize (by pressing the ctrl and minus buttons on the keyboard) to 67%. I verified this by opening the same web page in Brave, Chromium, and FireFox to do a side-by-side comparison. I confirmed font sizes were reset in all browsers and took a screenshot for this bug report.

It wasn’t until I performed this comparison that I noticed that tab sizes etc. are also larger on Brave. And while the larger UI elements are fine, websites themselves appearing larger is a problem.

Please see the attached screenshot. I have annotated the screenshot to add browser names.

How can this issue be reproduced?

  1. Open any website in Brave, as well as another browser for comparison.
  2. Compare the two windows.

Expected result:
Web sites look consistent with their intended font size.

Brave Version( check About Brave): v1.57.57

Additional Information:

  • Please note that I don’t see this behavior on MacOS where website fonts, as well as the browser itself look similar between Brave and Chrome; this problem seems to be limited to Linux (Debian 12, KDE).
  • Another interesting data point. On a maximized window, Brave returns window.screen.availWidth as 2283 while Chrome returns 3840. This being a 4k monitor, 3840 is the correct number. This is why the screenshot shows a different layout of the page in Brave vs. Chrome/FF. The page in Brave is rendering a smaller media breakpoint.

Have you tried checking your settings under brave://settings/appearance? And is this all sites or just some?


Greetings Saoiray, thanks for looking into this.

  • I reset preferences before I took the screenshots to make sure I was at default zoom levels etc. My font size is to Medium, and page zoom is set to 100%.
  • I’m seeing this same behavior with all websites.


Yahoo homepage in Brave vs. Chromium

@simiacode Part of me is wanting to assume it might be browser settings on Chromium or extensions (as I at least see you using extensions on Chromium). However, my testing can only be on Windows and I know you said that this doesn’t occur on MacOS and all, sayin git’s just a KDE issue from what you can see.

I’ll tag in @Mattches in hopes he can test or have some more feedback for you.


Personally, if I saw your screenshots on Chromium vs Brave on last post and had to say which font was messed up, I would have said Chromium was. That’s way too small to read, lol. I’d honestly think you have the chromium one on Small and now the Brave on Medium.

Also, testing just now, I don’ t even know how the font is supposed to work anymore. Originally I tested while like here on and I thought somewhere else. When I changed the font size, it changed on the websites as well. But just testing it on Yahoo and Reddit, the sites didn’t change at all when I changed font size. So yeah, definitely will hope @Mattches can clarify things a bit on the settings as well.

If the font sizes weren’t showing normal in the other browsers I’d say it was system settings causing this but now I’m not sure. I’ll have to ask someone on Linux team to check and see why this might be the case.

I think it might be more useful to look at why Brave thinks availWidth is 2277px instead of 3840px.

I have taken a new set of screenshots in incognito mode to make sure it’s not an extension causing the discrepancy. Also, a screenshot of Chromium’s appearance settings to show that it is set to medium font and 100% zoom.

Appearance settings

Brave and Chroium side by side on 4k desktop


All browsers full screen on 4k desktop (3840x2160)


Shows availWidth as 2277; should be 3840 as there are no scrollbars etc.


Shows availWidth as 3840


Shows availWidth as 3840

It sounds like no one else has reported this issue :sweat_smile:. So to make sure it’s not something related to my system settings etc., I will purge and reinstall Brave tonight and see if anything changes.

Thank you both for continuing to investigate this report :+1:.

1 Like

No your not the only one, I also have exactly the same issue (running on Kubuntu with KDE plasma 5.24.7).

I had to revert back to 1.56.20 to get normal font sizes (without zoom effect - which affects all parts of the browser including the browser window).

Hopefully somebody has a solution.

:wave: Hey folks. I’m sorry it took a while, but I finally found time to remove the browser (apt purge brave-browser), remove the profile directory (mv ~/.config/BraveSoftware/Brave-Browser ~/.config/BraveSoftware/Old) and then install a fresh Brave (apt install brave-browser).

Unfortunately, that didn’t fix the issue. Sizes continue to be too big, and window.screen.availWidth continue to be 2279 (instead of the expected 3840).

I understand Brave on one particular distro might be a small number of users, so a solution might not be forthcoming soon :slight_smile:, but at least we now have a bug record in case someone else runs into the same problem.

Thanks all.

Sorry, another update.

Just installed another browser (Vivaldi) and that one shows the same issues, right down to the window.screen.availWidth. Odd that this should be different between where Chromium and FireFox show 3840, while Brave and Vivaldi show 2277.

At this point I have no idea what’s happening :sweat_smile:. I’ll just use Chromium/FF when I’m doing web dev for now :man_shrugging: while continuing to use Brave for my day to day browsing.

I’m running into the same issue with Brave (and the same happens in Vivaldi when I tested it) but not with Firefox on Arch. I’m also running KDE Desktop. My desktop is 2560x1440 but strangely I’m getting my screen width reported as 2276 by Brave.

@mikewaggs glad to know it’s not just me. Can you please

  1. Confirm that you have checked your appearance settings
  2. Try out Chromium as well?

Thanks a ton!

  1. I checked out my appearance settings to make sure that I had no scaling setting setup and I didn’t.
  2. I’m experiencing the same issue with Chromium surprisingly.

Thanks for confirming these :+1:

  1. Settings: no scaling applied
  2. Chromium works well for me (doesn’t has this problem at all).

I was testing something with Wayland and noticed that this issue doesn’t occur. I’m assuming it’s tied to KDE Plasma and X11?

@Mattches and @steeven just wanted to tag in to loop around as conversation is still occurring here. Also not sure if any of their extra info since might be helpful.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.