FIXED: Fast Touchpad Scrolling Using ELAN Touchpad

windows
#1

Description of the issue:
Two finger scrolling using ELAN touchpad (ThinkPad) is very fast compared to other browsers.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Two finger scroll on touchpad

Actual Result (gifs and screenshots are welcome!):

Expected result:
Smoother scrolling similar/identical to other browsers

Reproduces how often:
Every time

Brave Version(See the About Brave page in the main menu):
Version 0.60.47 Chromium: 72.0.3626.119 (Official Build) (64-bit)

Reproducible on current live release (yes/no):

Additional Information:

My apologizes if this format is incorrect above. I’m just getting started with Brave browser and immediately encountered a potential show stopper. The touchpad scrolling was too fast. Searching online didn’t find anything that helped. I eventually uncovered some vendor specific (ELAN, ThinkPad) driver registry values that immediately fixed the issue. I just joined the community to share my findings. Hopefully this can help others.

Assuming you are using a laptop with ELAN touchpad and using ELAN drivers. I’m running a Lenovo ThinkPad Yoga 14 Windows 10 64bit with an ELAN touchpad, but I would assume this may work with other similar ELAN touchpads.

Import these registry settings to define scrolling behavior for brave.exe. Reboot and enjoy smooth scrolling! I’m loving this browser so far, so glad I was able to make scrolling work!

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Elantech\APOptimize\Brave Browser]
"Text"="Brave"
"Class"="Chrome_WidgetWin_1"
"FocusText"=""
"FocusClass"=""
"FileName"="brave.exe"
"FileVersion"=""
"Option"=hex:01,00,00,00,00,00,00,00,00,00,01,00,00,00,00,00,00,00,00,00,00
"Scroll"=hex:01,01,01,01,b9,9b,7d,5f,41,32,28,1e,a0,84,6c,58,48,3c,34,30,01,02,\
  05,07,0a,11,23,4b,02,5d,02,02,5d,02
"Zoom"=hex:58,28,18,10,0c,08,02,02,58,28,18,10,0c,08,02,02,01,02,05,07,0a,11,\
  4b,4b
0 Likes

closed #2

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes