Fix to brave using to much CPU?

is there a fix for the browser using too much cpu? when ever i play a video it uses 15-30%+ of the CPU, i like to listen to music while i play games so is there a way i can reduce the browser from taking so much CPU?

Have you disabled HW acceleration?

just turned it off will see if it fixes it

@Retro it should be the opposite. I think the hope was that you had it off already. Hardware acceleration, when turned on, tries to help pass off some tasks to your GPU so that there is less of a burden on your CPU.

As you can imagine, having hardware acceleration turned off means your CPU handles everything. Meaning you should see a higher CPU burden.

Part of what might help is if you can try using Brave’s task manager. The keyboard shortcut for this is Shift + Esc, though you can also go to the hamburger menu imageMore ToolsTask Manager to open it as well.

This will show all the processes running within Brave and where the usage is coming from. While it can vary, often it’s due to extensions that you have running.

its coming from the browser and GPU process

I am facing same issue when I am playing some online game from infopulsepro, otherwise its ok for me. just seems to be game guides, and the pages loaded fine

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.