Facing issue using Facebook on Brave

NOTE: Any “one-liner” or topics requesting support or reporting bugs that do not make an effort to include as much of this information as possible will not be responded to. Repeatedly posting as such is grounds for banning._
Please try to adhere to this template when reporting bugs. If you think you don’t need to fill out every section in the template fill out as much of it as you can and please be as descriptive as possible when posting.
<---------Delete this line and everything above before posting---------->

Description of the issue:

Steps to Reproduce (add as many as necessary): 1. 2. 3.
open facebook.com in brave browser

Actual Result (gifs and screenshots are welcome!):
Brave keeps on showing processing in tab title.
When try to scroll on the facebook feed, doesnt show anything (plain blank white page). Looks like not loading the content. If keep on trying Brave shows a pop up, either Wait or exit. Clicking on wait doesnt help as content isnt loaded. Exit just stop website and snaps. This is happening like from 2 weeks back. Facebook works ok on edge and chrome.

Expected result:
Facebook website should load without any error.

Reproduces how often: : Everytime

Operating System and Brave Version(See the About Brave page in the main menu):

Brave version : 1.67.116
OS details : Edition Windows 11 Home Single Language
Version 23H2
OS build 22631.3737
Experience Windows Feature Experience Pack 1000.22700.1009.0

Additional Information:

Just noticed, same is with youtube. Doesnt load fully and keeps on showing loading.
Again youtube works fine on Edge and other browser.