Extremely slow startup

Description of the issue:

For the last 4-6 months, every time I start Brave, it hangs for at least 20 seconds before it becomes usable (cannot enter text in the URL bar or anything). I have tried disabling every setting and extension I can think of, but nothing has helped.

How can this issue be reproduced?

  1. Open Brave.
  2. Wait.
  3. Wait some more.

Expected result:

Brave opens and is immediately usable, rather than having to wait 20 seconds.

Brave Version( check About Brave):
[Version 1.10.97 Chromium: 83.0.4103.116 (Official Build) (64-bit)]

Additional Information:
Windows 10 Pro (64 bit)

I’m having the same issue.

  • MacOS 10.14.6
  • Brave Version 1.10.97 Chromium: 83.0.4103.116 (Official Build) (64-bit)

I’ve tried disabling all extensions, but the problem persists.

1 Like

Hello!
Go to web compatibility and see what will happen.

I’ve had the same issue for months now, figured it’s time to figure this out. My wait time is significantly longer… upwards of 5min on launch.

MacOS Sierra 10.12.6
Version 1.11.82 Chromium: 83.0.4103.116 (Official Build) dev (64-bit)

Did some digging and found the following solution…

Clear browsing data->Time range->All time and Checking only “cookies and other site data.”

Source:

No more hang on startup.

2 Likes

Thanks!! Amazingly that seems to have solved it.

2 Likes

Wonderful solution @darkness22. Thanks for taking time to share. It worked perfectly for me. I had been turning off extensions like a madman. Nothing like removing all your favorite browser functionality to (not) solve a mystery problem.

I wish Brave would find another way, though. I like having the cookies I choose to have. Now I’m starting from scratch with cookies.

1 Like

Following up a month later.

Version 1.12.104 Chromium: 84.0.4147.89 (Official Build) dev (64-bit)

Now have a massive amount of cookies.
Brave is still starting up normally / quickly with no issues.

Have also tested from a single empty window all the way up to 20 windows with 1-6 tabs in each. Even under this heavy load, startup is very fast.

I’m searching for a Chrome Extension that can test / evaluate a cookie for faults. Unsure if that actually exists at this time.

Regardless if anyone is experiencing a slow startup, try the fix above.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.