Extensions Tab in Toolbar


Is there a way to remove the extensions tab on the toolbar?
When I unpin or close it, it automatically comes back automatically.Screen Shot 2020-09-06 at 9.25.08 AM

brave://flags - search for ‘extensions toolbar menu’ and set value to disabled

Thanks for your reply. Sorry, I’m new to Brave. What does brave://flags mean and where do I find the extension toolbar menu?

Type brave://flags in the address bar and hit enter… then type in ‘extensions toolbar menu’ in the search box… then choose disable in the dropdown…

I followed the instructions but without success. The extensions tab remains in the toolbar.
Is there any other way to get rid of it?

You restarted the browser, right?

Yes, I restarted the Brave twice, unpinned the tab, closed the tab… it’s still there.

I guess can we get a screenshot of your whole browser and a listing of any extensions you got installed? I wonder if what that icon is an actual extension and not the toolbar extension button…

Yes, sure.

hrmmm… if you enabled the flag, does your brave change appearance? Like do you see an extension toolbar icon where the extensions icons are to the right of the address bar?

The icon for me, is to the right of all the extension icons… I can’t even move the icons to where you have 2 icons next to the window buttons… :thinking:

Edit: What version of brave also? You’re using the latest version?

That’s weird; the appearance of Brave isn’t changing, no matter if the flag is enabled or disabled.

I’m running the latest Brave version (Version 1.13.82 Chromium: 85.0.4183.83 (Official Build) (64-bit)

Yeah… I don’t know… You could try to uninstall brave and nuke the brave install completely like when using something like AppCleaner… Then reinstall brave and see if thing start working for you…

Or hangout and see if anyone else has any ideas… I sure don’t… @Mattches would you have any ideas on this behavior?

Edit: you can try to also disable all extensions and see if the browser behavior changes back to correct behavior…

I uninstalled Brave with CleanMyMac but the extension tab is still there.
Also, disabling the extensions didn’t fix the problem.

@megaspaz @CooperOnTheRun,
Displaying the extensions toolbar menu by default was a change in the Chromium code and was subsequently inherited with an update. That said, I believe we intend to keep this menu as is for the time being. I will double check on this, as well as see if we plan on adding an option at any point to toggle this menu on/off.

From playing with the flag, yes, it looks like it’s enabled by default, and disabling the flag for me actually does disable the extensions button on both mac and windows on the latest build, with my mac being on mojave… but @CooperOnTheRun seems like setting the flag to disabled does nothing… why the difference between me and @CooperOnTheRun? @CooperOnTheRun, I’m assuming you’re on catalina or big sur? The only other diff i can think of…

Edit: the placement of the extensions button in his screenshot is also puzzling…

1 Like

Yes, I’m on Catalina . And yes, the flag is enabled by default.
The extensions tab sits on the left side of the toolbar. Unpinning and closing the tab doesn’t work. Very annoying because it’s directly in the row with all the other pinned tabs.

Well I just made a catalina vm and installed the latest brave and the behavior matches that of mojave for me, so your issue is really frigging mind boggling… :grimacing:

Can you do me a favor and try creating a new browser profile (Menu --> Create Profile) and see if the extensions tab appears there too? It shouldn’t, and you shouldn’t see the one that appears on the right either:
If this is the case, can you then try adding one extension to this new profile and see if the menu pictured above appears as it does in the image for you?

I have created a new profile and the problem seems to be solved. The extensions tab is gone and will not return when I install and active extensions.
Thank you @Mattches!
And thank you @megaspaz for not giving up on this and your efforts!

I don’t want to hijack but how can I delete the old profile?

1 Like

If you want to delete the old profile, simply click on your profile icon:

Then Other profiles --> More options --> Remove this profile: