Error Missing X server or $DISPLAY on brave on Ubuntu mate

i run a container ubuntu mate on debian 11 but when i run Brave in ubuntu mate i have the message:

root@0b3bd7aba275:/config# /bin/brave-browser [6194:6194:1116/] Running as root without --no-sandbox is not supported. See

root@0b3bd7aba275:/config# /bin/brave-browser --no-sandbox [6220:6220:1116/] Missing X server or $DISPLAY [6220:6220:1116/] The platform failed to initialize. Exiting. /bin/brave-browser: line 48: 6220 Trace/breakpoint trap “$HERE/brave” “$@” root@0b3bd7aba275:/config#

i install Gnome on debian but same issue.

when i did docker run i mounted tmp file with all X0,X1,X10,X1024,X1025 on ubuntu mate and when i run brave i have same error.

docker run -d -v "/tmp/.X11-unix/:/tmp/.X11-unix/" -e PUID=1001 -e PGID=1001 -p 3003:3000 --shm-size="1gb"

do you know the problem ?

Hello @glardz

Thank you for reaching out and sorry to hear you’re having trouble with Brave. Could you share the following:

  1. Brave Version.
  2. Device OS version.

Please update to the latest Brave version. Be waiting for your response and have a nice day!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.