Ubuntu Server install is “Missing X server or $DISPLAY”

Installed brave-browser following instructions from brave.com on my orange pi 5 running Ubuntu server 22.04 Jammy Jellyfish.

It attempts to run it but throws this error and exits.

. . . ozone_platform_x11.cc(239)] Missing X server or $DISPLAY

Seems to be the same error reported by @glardz in Nov ‘22 which is stale

I’ve got the same error using the Wayland version of KDE plasma on linux mint. (Not on the X11 version though). I got it working using the normal brave-browser rather than the flatpak. Haven’t tried the SNAP but it might work.
Not much help on what is actually going wrong though.

Solved I think (at least for flatpak if you are on wayland) . Try running flatpak run com.brave.Browser --enable-features=UseOzonePlatform --ozone-platform=wayland

If that works then edit com.brave.Browser.desktop replacing instances of EXEC=… with EXEC=flatpak run com.brave.Browser --enable-features=UseOzonePlatform --ozone-platform=wayland

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.