Error 500: Internal Server Error when trying to connect my Uphold account

Same thing with Gemini, adding a channel works.
My Uphold account is fine and trying on another browser don’t change anything.


Same here can we get some update on this?

1 Like

Sure. I will try to update, have tweeted to brave support and @chriscat since most likely support isnt going to be active here since a weeken in the US.


I am from Argentina and the exact same thing happens to me, I enter my creator account and it appears "Error 500: Internal Server Error :thinking:
Oops, sorry about that. You can try to refresh the page or return to

For assistance please contact us at"


I’ll be updating this topic as I get more more info.


Hi all, can you try this? Press the lock icon in the URL > Site settings > Clear data, then try again. In other words, clear your cache and cookies for the Creators website.

Let us know, thanks.

I just tried, it doesn’t change anything.

Thanks. And just to be 100% sure, you did this clear site data on the actual Creators site (, right? And then tried again and it still showed a 500?

Yes, that’s what I did.

@Tutez Can you go to the Creators site, right click > inspect > console, and then create the 500 error. Then see if there are any errors that show up in the console? Can you copy-paste for us?

@SmartyAadi Is this reproducing for you too? If so, maybe we can do a 1:1 call so I can gather more information.

Only this:

This error is occurring for me too. Disconnected the uphold wallet and while trying to reconnect exact same error occurs. I think easy to reproduce the error on your side: just disconnect the uphold wallet and try to connect again.

I am also experiencing this same issue.

Was working fine till I was just opening the site. As soon as I tried disconnecting my Gemini and connect to Uphold I got the error.

This is what I get on mine.

Thanks. Does it work in a Private Window for you?

Nope. Same results. Tried on another device too, same results. Doesn’t matter Android or Windows.

@chriscat it seems to have been solved for now. I tried just now and it does take me to Uphold. Was able to connect to Uphold successfully!

1 Like

The same thing happened to me, I just entered my creator account, something strange seems to fix the problem on its own?

Seems that the creators team made some changes on the backend.

1 Like