Erroneous scroll behavior on Mac OS with "Jump to the spot that's clicked" enabled

Description of the issue:

On Mac OS, I use the system option, “Click in the scroll bar to: Jump to the spot that’s clicked.” Brave’s behavior when this is enabled is erroneous and different than the standard behavior. Specifically, when grabbing and dragging the scroll bar itself, the scroll bar should act as if it has been grabbed: it should be drug by the cursor and remain in the same relative position with the cursor. Instead, Brave causes the scroll bar to jump instantaneously so that the center of the scroll bar is beneath the cursor.

How can this issue be reproduced?

  1. Enable “Jump to the spot that’s clicked” in System Preferences → General
  2. Open any Web page that is long enough to trigger a scrolling view
  3. Grab the bottom end of the scroll bar and start pulling it down
  4. Notice that the scroll bar jumps to be centered underneath the cursor

Expected result:
The scroll bar and cursor should stay locked together as if the cursor had grabbed onto the scroll bar and is moving it.

Brave Version( check About Brave):
Version 1.44.112 Chromium: 106.0.5249.119 (Official Build) (x86_64)

Additional Information:
Video demonstrating correct behavior (using Firefox as an example):

Video demonstrating behavior in Brave:

1 Like

Hello there @aogaill please accept my apologies for this inconvenience. Does this issue happen when scrolling down on other Browsers or only happens if you do it on Brave?

In the meantime, can you try disabling Hardware Acceleration in settings to see if this resolves the issue? You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Be waiting for your response.

Thanks @Kevin_cc.

I’ve only observed the issue with Brave. Other browsers I’ve tried, such as Firefox and Safari, behave consistently with the rest of the system. You can see Firefox’s behavior in one of the videos I linked in my original message.

I disabled Hardware Acceleration, relaunched Brave, and it still exhibited the erroneous scroll bar behavior.

For what it’s worth, since my original post, I have kept up to date with Brave updates and am now on Version 1.45.123 Chromium: 107.0.5304.110 (Official Build) (x86_64)

1 Like

Hello again, thanks for the information provided. Could you please try opening your main profile in private or guest mode to see if you experience the same issue? If the issue does not happen, try disabling your extensions to see if this is the cause of the issue.

You can open a Guest Window by going to Main menu --> Open Guest window:

  1. On your computer, open Brave.
  2. At the top right, click Menu → More tools → Extensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.

Hi @Kevin_cc, I tried guest mode (and just for fun disabled all my extensions) and neither changed the scroll bar behavior I described.

I even just logged in to my computer using a Guest session to eliminate all possible user-specific stuff and Brave’s scrolling behavior did not change. You (or anyone who works on Brave for Mac) should be able to follow my steps to reproduce and see the issue yourself.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.