Page jumps using arrow keys

Hello,

First I’d like to thank the Brave devs and community. It’s been an amazing experience since last year.

In a quick search I didn’t found a similar issue, so thought I should create a new topic. This problem started just a few days ago, so it’s probably due to a recent update. I should say I don’t believe it’s extension related, considering I use very few of those (<5, some even inactive) and haven’t installed any for a good while.

Issue is: I use “Home”, “End”, “Page Up”, “Page Down” and arrow keys a lot to navigate. First I noticed a text cursor appears between the page content when I use arrow keys, and it has to reach top or bottom in order to start scrolling up or down. In normal conditions, it doesn’t, and in fact it doesn’t even show this cursor.

Second is: sometimes (and i say this because although it happens very often, it’s not every time) when I hit just once the up arrow, instead of going up just a bit, the page jumps all the way to the top. This is specially annoying, as it affects browsing experience considerably. It’s also a bit irregular, sometimes (rarely) it doesn’t happen.

Here I should detail how it can be reproduced, but I don’t know exactly how to describe this. The text cursor always shows up for me (I tried uploading a screenshot for this). The page jumping is a bit irregular, but happens frequently.

I’m thinking this one will be very hard for devs to come up with a solution, but my hope is more users see this and relate with something close to this topic. I don’t want to stop using Brave :cry:

" Brave is up to date

[Version 1.15.75 Chromium: 86.0.4240.99 (Official Build) (64-bit)]"

I’ve tried to duplicate the issue without success.

Can you provide a website (or two or three) that exhibits this behavior?

Yeah, I thought it’d be difficult to reproduce. As for the website, not sure I can help. It happens in every website, really. I noticed the page jumps back to where the text cursor is, so the problem is in fact this cursor appearing.

Gonna wait for the next update, maybe it’s fixed, maybe it imports a chromium fix, i don’t know. I haven’t tried reinstalling yet because of concerns regarding settings, sync w/ devices, rewards. But if no fix updating, might try to do that and report back. Thanks for the reply anyway.

yea, reinstalling seems extreme.

crazy thought… maybe install Brave Dev (or Brave Nightly) and see how it behaves?
you can run multiple versions on the same machine.

1 Like

I had the same problem, now, I find out that brave has a “caret browsing mode”, we probably turned on accidentally with F7 key. I thought that was a bug. [edit] That mode you navigate with the text cursor

1 Like

@daninshit hey man, thank you very much! Didn’t know about that mode, so it turns out it was my bad as well, no bug.

@caldercay always hear about those Brave versions, never tried it. Don’t really know what it’s about, but thanks for reminding me of those.

This was my first topic here, so i don’t know if i’m required to delete it. Even though it wasn’t a bug, I checked @daninshit reply as solution anyway. Thanks mate!