Downloads taking a long time to "finish" even after completion

Description of the issue: When I download a file, even a small one, there seems be 5-10+ seconds when something is happening to the file before it “completes” and let me access it. The same process in Chrome is instantaneous.

Steps to Reproduce (add as many as necessary): 1. 2. 3. Just download a file… even after it’s fully gotten all the info, it just waits several seconds before the download looks complete.

Actual Result (gifs and screenshots are welcome!):

image

This file is not accessible yet.

Expected result: Should complete instantly after downloading all the info

Reproduces how often: Every time

Operating System and Brave Version(See the About Brave page in the main menu):
Version 1.10.95 Chromium: 83.0.4103.106 (Official Build) (64-bit)
OS X Mojave 10.14.6

Additional Information:

The actual problem can be caused by hard drive issues or acessing policy.
The fact that it turns up when the actual filename is changing made me think so.

  • On the last downloading step the browser changes name of the file from %filename%.not.accepted.crdownload to %filename%.%extension%

Also it can be menu entry/file association events, have no Mac SAA experience to say clear

Hrm, thanks. But on Chrome this doesn’t happen, so wouldn’t that rule out hard drive or permission issues?

Hi @earlybird,
Can you go to https://www.w3.org/WAI/ER/tests/xhtml/testfiles/resources/pdf/dummy.pdf when you download this test PDF, does it also wait for 10-15 seconds?

Hi there – yes it does. About 6 seconds post-download to be precise in this case.

@earlybird
Can you try creating a new test profile and seeing if the issue persists?
Click on the menu icon in the top right corner > create a new profile.

All right, I just tried that. No dice. Still a delay, even with a new profile.

Are you using a VPN or any anti-virus software?

I have a VPN but it’s not on. I did have anti-virus on but I turned it off and the problem stayed the same…

1 Like

I’m pretty sure @Mattches or @sriram have mentioned this before. Something like related to file scanning for virus.

Can you download the test pdf again but also record it and send it to us. We’d like to have a better look at what’s going on.

By record it do you mean a screen recording of me downloading it? Or something else?

@earlybird
Yes, screen recording!

Huh, I’m too new a user to be allowed to upload attachments, so here’s a link to my screen recording:

(EDIT: replaced it with a video where I made sure anti-virus was off… same thing happens)

@earlybird,
Thanks for sharing the video, I’ll look into this and get back to you.

thanks. just fyi I changed the video – this time I made sure anti-virus was off. But the same thing happens.