Distorted font (characters) in some webpages

Another example:

Another example:

Does it work in private window mode?

Same problem in private mode.

Use Font default font as Times New Roman and Arial and font size in between 16 and 18; Fixed-width font as "consolas

@leoff Previously had instances of font distortion using aggressive fingerprinting. May be a regression? Try changing fingerprinting settings and see if behavior changes.

bsclifton commented 3 days ago

The thing I’d ask folks to check shield settings specifically on the site where they have the problem and ensure you have Block fingerprinting (or Allow fingerprinting, but that’s not preferred) and not Aggressively block fingerprinting

Another font problem topic that may apply:

Finally, since this post is older, please post an update to your current Brave version.

Take care. :slightly_smiling_face:

@Chocoholic: Your links don’t work. They do in Chrome…
My Brave version: Versie 1.46.144 Chromium: 108.0.5359.128 (Officiële build) (64-bits). This is the Windows desktop version.
I have the same problem in Guest windows.
Do fingerprinting settings apply here?
I have the same font settings as in your second image.

No idea. They work for me. I did go edit just to. Please try again if you get a chance.

Link to the issue report with the comment. It is the last comment on the report. Issue #23093 in case this link doesn’t work either, you can pull it up at Brave GitHub.

win10 or win11 or earlier version?

There was a problem previously with fingerprinting and distorted fonts but it was fixed. I was just posting information from past problems in case there was a regression Brave dev needs to look into. If you tried the fingerprinting suggestion or even tried a different fingerprinting setting, then this issue probably does not apply.

There was another suggested workaround in that post you might want to try. Posting link and quoting just in case link doesn’t work.

Posted by @289wk

Close / Exit / Quit everything.
In the address field of Windows Explorer, enter:


That should get you to the Fonts folder.

Move all of the

  • Helvetica
  • Helvetica neue

. . . fonts, to some other folder.
Restart your Windows OS machine.

To confirm, the font distortion is only happening in Brave and not Chrome, correct? Also, have you tested in a new profile, Brave Beta, and/or Brave Nightly? You might try to test to see if the font distortion behavior occurs there also. The additional information will probably help troubleshoot.

FYI: I also experience this issue. Can’t remember when it popped up. I use a gaming mouse so thought that initiated the problem so was living with it and it usually: cleared itself after a few seconds, if I used left-click on the page, or if I engaged mouse wheel. Not any one particular thing worked every time. Very random occurrence in my experience.


  1. win10
  2. Gaming mouse
  3. Occurs in new private window, all profiles, newly created profile, and all versions of Brave (Release, Beta, Nightly)
  4. Tested disabling/enabling HWA and Vulkan individually and in combo and still occurs.
  5. Tested by changing fingerprinting settings and still occurs.
  6. Default font settings.

Will test the Helvetica font thing and post an update if it changes anything.
7. Update: No Helvetica fonts in font folder
8. Update: Distortion does occur in Chrome and Edge


  • Your links now work.
  • I use Windows 11 (x64), build 22621.963.
  • Any setting of Fingerprint gives same result.
  • I don’t see any Helvetica font in the %WINDIR%\Fonts directory.
  • There is no distortion visible in Chrome.
  • Disabling Shields does not solve the issue.
  • The issue goes away when setting focus to some other window, or moving the mouse pointer over the distorted text.
1 Like

Does adjusting the hardware acceleration in brave://settings/system help?

@fanboynz: See my answer some time ago.

Distortion does occur in Chrome and Edge too on my system.

What I notice is that in Brave parts of the text is distorted and becomes normal after some time. This time can be from <1 sec to infinite. I do not notice this in Chrome. Maybe the distortion is there but vanishes before you can see it.

@leoff Unfortunately, since this occurs in other browsers, this is probably an upstream issue that won’t be fixed until Chromium releases a fix. I tried to look to see if the issue was reported at the Chromium Bugs/Issues reporting site but couldn’t find anything. Doesn’t mean it isn’t there, just means I couldn’t find!

@Mattches @fanboynz Can you provide any additional information about this issue?

@leoff are you 100% sure that the ClearType adjustments do not make any difference? This looks very much like that is the issue here and/or HWA (but you seem to have already tested this).

It is likely system related, rather than browser related in this case. I thought it may also be due to some sort of conflict with an extension you have installed, but if you’re seeing it in Chrome as well then that is likely not the case.

Yes, confirmed ClearType adjustments do not make a difference.

Confirmed default settings in Brave same as in linked post. Tested by changing fonts in Brave from default then back. Then changed fonts to something other than default, cleared browsing data, exited and reopened browser. Also tested changing various system font settings and did not make a difference. Also made sure ClearType was enabled on system and went through fine tuning. Distortion still occurring.

Noticed distortion is now occurring in Nightly too. Couldn’t make it occur before.

Edit: Other things tried

  1. Changed gaming mouse to standard wireless mouse. Distortion still occurs.
  2. Rebooted computer. Distortion still occurs.

Just wanted to add that although the distortion still occurs, it seems to now clear itself and not appear as often. I test using Community search. I notice if I drag the page scroll bar down quickly, the distortion occurs. It also occurs if I rapidly use the mouse wheel repeatedly but not as often. It is now correcting itself when I release the mouse wheel or scroll bar whereas before that was not a sure thing.

Just curious, is there some kind of “font cache”? Is that a thing? If so, could it be getting “glitched”? If not, go ahead and have a good laugh. :joy:

I know that a lot of users here are on Windows, but for anyone seeing this on macOS, can you please open the Font book application, click on the top-most font, hold Shift then click on the last font in the list (to select all fonts), then right click on them and select Validate and ensure that you get green checkmarks for all fonts.

Indeed. I notice this on the very page you are viewing now.