Brave browser displaying thin fonts

Description of the issue:
brave browser is displaying narrow and near unreadable fonts on some sites (not all sites are affected, but those that are are consistently problematic.) I’ve noticed particularly ebay and mythweavers. I’ve found a number of other people mentioning this on the forum but not found a suitable response.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
open site

Actual Result (gifs and screenshots are welcome!):
image taken from the bottom of ebay page

Expected result:
any readable font would be preferable.
Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

Edition Windows 10 Home
Version 21H2
Installed on ‎22/‎03/‎2021
OS build 19044.1645
Experience Windows Feature Experience Pack 120.2212.4170.0

Brave is up to date
Version 1.37.116 Chromium: 100.0.4896.127 (Official Build) (64-bit)

Additional Information:
have tried clearing the cache and restarting
have tried running in a private window without extensions
have tried customising fonts in brave settings
have tried disabling hardware acceleration and disabling brave shields
have tried switching to a guest profile to eliminate user profile settings as a factor.

none of these had any effect.

Thank you for reaching out and for the detailed report. I’m wondering if this is a MS ClearType issue:

Can you check and see if Cleartype is enabled or disabled? If enabled, can you try disabling just to check and see if this fixes the issue? If disabled, please try enabling it and test to see if the issue persists.

Thank you

I disabled it, but it doesn’t seem to make any difference.

@toastercide ,

For reference. On a Mac. Brave Browser (v1.37.116) > Settings:


(Edit:) THERE, Standard, Serif, and San-Serif Brave Browser fonts are/were set to Verdana. (Since posting, some testing of Helvetica neue, to see if matching with the font-family reported by Developer Tools, significantly changes appearance.)

Meanwhile, the Developer Tools display, reports that the font-family is:

“Helvetica neue”, Helvetica, Arial, sans-serif

NOTE: The following screenshot does not display well – after uploading into the Brave Community Reply Editor window – as a .JPG file, so I saved the screenshot as a .PNG file. The website is actually

Generally speaking, you’ll want ClearType to be enabled.

Here is what was shared, overlayed against what I personally am seeing. Note that the issue is not merely the font used, but also kerning, and weight.

How are your settings in brave://settings/fonts/ configured? Below is what I have, and what I believe are the default settings:

I would also encourage you to test the page in a Guest Window (via the ☰ menu) to see if that yields a different (better) result. If so, the problem could potentially be with an extension you have installed.

1 Like

I checked my fonts on my brave browser already.
standard and serif are both times new roman and sans serif is arial. fixed width is consolas. I have my font size to 20 and minimum to 14.
I tried changing those but it had no effect.
I have clear type back on now as it was before. still no change.

I also tried using a guest profile, it was the same.

@toastercide ,

A test:

Close / Exit / Quit everything.

In the address field of Windows Explorer, enter:


That should get you to the Fonts folder.

Move all of the

  • Helvetica
  • Helvetica neue

. . . fonts, to some other folder.

Restart your Windows OS machine.

I deleted the helvetica fonts entirely.
one of them was locked because it was in use by the system.
I used an unlocker to auto delete it on restart and when i restarted the problem was solved.

thanks heaps for that.

not sure why my system had latched onto that font. could be a problem later when i need to use that font again, but at least i know where the problem is if it happens again.

very much appreciated.

1 Like

@toastercide ,

I found the idea, online, while originally searching for info on how to add/remove fonts aboard a Windows OS machine.

Somehow, a “font-family” that includes both Helvetica and Arial fonts, leaves an avenue for both fonts to be applied, per character (possibly a Blink > font rendering bug/thing?) – such that, one of the fonts, blends with / overlays the other . . . and the result causes some washout.

I did not use exactly, the following search criteria, as I stumbled along:

“remove “Helvetica neue” conflict with Arial fonts”

. . . but close to that, as my search criteria developed . . . as I found info about conflicts caused by (or allegedly caused by) font: “Helvetical neue”.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.