Display bug with Brave

Hello, I contact you because since I bought my mini PC MAGNUS ONE ECM73070C with a graphics card RTX 3070 I find that sometimes the display of web pages bug with your browser Brave. When I use Microsoft Edge and Google Chrome I don’t have this problem. Can you fix this? Or do I need to disable hardware acceleration in the browser settings?

Hello @tenchu76

Thanks for bringing this to our attention and sorry to hear you’re having trouble with Brave. Can you try disabling Hardware Acceleration in settings one more time, to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Let me know if that works and have a great day!

Hello, indeed this has solved the problem but suddenly it is slower the loading of the pages.