Disable auto-brightness when the video is in full screen?

Description of the issue:

On Brave browser on my PC, when I play a video(youtube, twitch…) in full screen the brightness of the monitor increases automatically when my ac adapter is plugged.

How can this issue be reproduced?

  1. Play a video on full-screen on any website

Expected result:

Brightness of the monitor increases automatically.

Brave Version:
v1.61.109

Additional Information:
This only happen on Brave, I found out when I unplugged my ac adapter before the full screen, it’s normal, I plugged in during the full screen the problem was solved, but now it’s not working anymore, and I try every options everywhere on a lot of forum, and nothing, there’s no disable for this, please help me.

@Jordan60 this shouldn’t be anything from Brave as it doesn’t really toggle brightness in itself. I would assume this is in your settings on the device. I’m not sure if I quite understand your situation though. Are you using a laptop and are saying only have this issue when it’s running on battery? I’m kind of getting lost as you’re mentioning mains battery and all.

Sory my english is bad, I mean on my ac adapter, and this not happen on Chrome, Firefox, only on Brave, you can see on google I’m not the only one, there’s other people who made a post here or on Reddit for this and it’s only with Brave

So it is a laptop? If so, it might be that settings for battery saver is in effect. Sometimes settings can be app/program specific.

Unless you speak a language not able to be translated online, go ahead and speak your main language. We can use translation programs to see what you’re saying and to try to respond. It is better that way than getting limited information due to language barrier.

Oui c’est un ordinateur portable.

Je viens de voir que dans mes paramètres de lecteur de vidéos, précisément pour Windows HD Color, il y a un test d’une vidéo en plein écran où l’on peut activer/désactiver le HDR en continu, et quand je l’active, la luminosité s’active comme sur Brave, mais le problème c’est que cette option est désactivé à la base, donc ça ne devrait pas le faire sur Brave

@Jordan60 Je vous prie de m’excuser de ne pas vous avoir répondu. Ce que vous décrivez ressemble aux options d’économie de batterie des appareils. Du moins, c’est ce que je pense en me basant sur la description que vous avez faite précédemment, à savoir que cela ne se produit que lorsque l’appareil est débranché. Ou ai-je mal compris ?

Par ailleurs, où se trouve ce test ? Ou comment fonctionne ce test ?

Oui ça ressemble à cela, mais il n’y a rien dans les options qui parle de ça.
Le test est dans les options de lecteurs de vidéos

Je vais essayer de contacter @Mattches pour voir s’il a une idée sur la question. Je ne suis pas sûr qu’il s’agisse d’un problème de paramétrage de votre carte graphique. Si vous désactivez l’accélération matérielle dans brave://settings/system, voyez-vous un changement dans le comportement ?

N’oubliez pas non plus que nous sommes samedi soir aux États-Unis. L’assistance n’est généralement pas disponible le week-end ou les jours fériés américains. Lorsqu’ils reviennent, ils essaient de rattraper tous les sujets manqués. J’espère que ce ne sera pas trop long, mais il se peut que nous n’ayons pas de réponse avant deux jours.

Non cela n’a rien fait malheureusement
Lorsque j’ai redémarrer mon ordinateur il y a 2 jours cela ne s’est produit, mais lorsque je l’ai relancé le lendemain cela a recommencé

@Jordan60,
Si vous allez dans Menu --> Plus d'outils --> Performances et désactivez le paramètre Économie d'énergie, voyez-vous toujours ce même comportement ?

Non cela ne change rien

@Jordan60,
Utilisez-vous Windows 10 ou 11 ?

@Jordan60,
Une autre réflexion : pouvez-vous s’il vous plaît essayer ce qui suit ?

  1. Ouvrez Brave et accédez à brave://flags/#force-color-profile
  2. Choisissez l’option sRVB
  3. Redémarrez le navigateur si vous y êtes invité

Faites-moi savoir si cela fait une différence.

sRGB vous voulez dire, cela ne change rien, et je suis sur Windows 10

J’ai juste allumé mon ordinateur aujourd’hui et ça ne le fait pas, à chaque allumage c’est un hasard

if you are plugged in and play a video on YouTube using Brave in fullscreen, the brightness automatically increases. otherwise, when not plugged in, the video is still at normal brightness

it is not in battery settings, it is just in brave

I Fixed it (Windows 10). If you’re on a Laptop, there’s a configuration in the Display settings you should take a look. In the “Brightness and color” that says “Change brightness for built-in display”, turn it to 100% then adjust the brightness manually in the keyboard while running a fullscreen video (usually a sun icon in the F11 using Fn key), after that the brightness stayed the same on any app.

1 Like