Dialog box causes browser to hang

windows
#1

I’m running Brave Version 0.61.52 Chromium: 73.0.3683.86 (Official Build) (64-bit) on a fully patched W10x64 machine. Only have two plug-ins loaded (LastPass & Currently)

Brave consistently hangs when a dialog box needs to open (e.g. file save), with no dialog box visible.

Is it a known issue? (I didn’t see it in ‘known issues’), or am I failing to do something correctly?

0 Likes

#2

@martin_l,
Thanks for reaching out. Would it be possible for you to take a short screen recording of hang when you open a dialog box?

0 Likes

#3

Yes! Hi I am new to this forum and have been facing the similar issue ever since I’ve started to read the threads for robux hacks. Definitely following this.

0 Likes

#4

@jaygummers,
Welcome to Community! :tada:
Can you provide some additional detail surrounding your setup as well as the issue itself?

0 Likes

#5

So, screenshot attached - nothing to see really. Browser needs to be killed from task manager. Every time I click on it I just get a ‘bell’ notification sounds from Windows, but no visible dialogue box. Alt-Tabbing through tasks doesn’t shown any hidden / popped-under dialog, and the only way to recover is to kill the Brave task in Task Manager.
I run dual screen, but get the same behaviour on single screen. It has occasionally managed to pop a file dialog box, but I can’t tell you why/when - that would be about 2% of the time.
Submitting this report using Brave didn’t work either (Chrome worked) - when I clicked the upload files and the ‘choose files’ button, Brave hung again.
Let me know what more you want to know about my system, or what you want me to do in the browser and I’ll send more info. Nothing really to tell from the screenshot, but right hand clicking the ‘full report’ button on that page and choose ‘save file as’ is what causes the hang.

0 Likes

#6

@martin_l,
Thank you for the additional information – really appreciate it.
I’m going to test this on my Win10 machine if you’ll allow me some time. In the interim, can you tell me if right-click --> Save As is the only time in which the dialog box causes Brave to hang?

For example, if you view the BAT Whitepaper pdf online and elect to download the file (you can set Brave to do this automatically in lieu of opening the pdf in browser, but for this example I’m assuming you open PDFs in tabs – please correct me if I’m wrong in thinking that) by clicking the Download icon on the top right of the PDF, does the browser hang here as well?

0 Likes

#7

It’s not only right-click --> Save As that causes it to hang. Other actions that call for a dialog box also cause it to hang.

I can see that PDF online, but when I click the download icon while viewing it online, the first left-click creates no apparent action, and a second left-click (or any other interaction with the browser) gives an error ‘bell’ from Windows (as it would do if the dialog box had opened and was waiting for input somewhere invisible).

I’ve attached a capture of that action no visible error, just ‘bell’ and hang after second click on download icon). Also, attaching a file to this post has to be done from Chrome, because Brave would hang for the Choose Files button in the file upload process for this post.

0 Likes

#8

@martin_l,
Thank you for your patience and for the additional information.
This is definitely strange – I don’t see this issue on my Windows machine nor do I see other reports of it. I’d like to try a few tests if you’re willing. Fairly straightforward:

  • Try disabling both extensions – I don’t think this is the issue but sometimes extensions cause some strange and often unforeseen conflicts with Brave. Disable them and test to see if the browser still hangs.
  • Try disabling Hardware Acceleration – Another issue that often causes problems where it probably shouldn’t. Generally these are graphics-based issues that HA causes but it’s worth testing here as well, especially since the test is easy. Simply disable it and see if performance improves (Settings --> Advanced --> System --> Hardware Acceleration)
  • Try running the Developer or Beta build and see if you get the same issue – These builds can be downloaded, installed and run without overwriting data or otherwise interfering with any other Brave installs currently on your machine. If you can browse and achieve intended performance in these builds, then we can rule out several possibilities in one test. If the behavior is the same, it’s likely something to do with your setup. If not, the issue is likely something specific to Release channel which we can start digging into further once we’ve tested.

Let me know what you find out.

0 Likes

#9

OK, tested:

  • disabling both extensions - same hang error
  • disabling hardware acceleration - same hang error
  • beta build - works correctly, tested maybe 10 different links, including system generated download dialogs
  • dev build - works correctly, but tested it a bit less.
0 Likes

#10

@martin_l,
Thank you again for your willingness to troubleshoot and test the issue. Really appreciate your patience.

While I’m still not entirely sure why the hang is specific to release, the fact that it works in both Dev and Beta implies that whatever is causing it has been addressed in one of these builds. Meaning that the fix will hit Release build a future update – likely the next update available.

That said, I would like to see if there any alternatives or theories for this issue, so I’ve reached out to some team members for additional input. I’ll leave this thread open and return with any additional information about the problem or additional steps to try.

1 Like

#11

Just updated to Version 0.62.50 Chromium: 73.0.3683.86 (Official Build) (64-bit) - same issue, browser still hanging when opening a dialog box (which doesn’t appear). In case I haven’t been clear, the ‘hang’ is really ‘browser waiting for input’ - the bell indication is the same as Windows gives if you open a dialog box in another application and then try and click elsewhere rather than interact with the dialog box. That makes me wonder whether Brave has opened a zero size window, or opened it off screen somewhere (although I see the same result if I’m running one screen or two screens). Cycling through open apps (Windows ALT-TAB) doesn’t show any indication of a dialog box open.

Is there some debugging I can turn on to give you a better handle on what’s causing this?

Edit: added bell explanation

1 Like

#12

@martin_l,
Appreciate the diligence and patience as we work through this. I’ve reached out to a few team members for some additional input/fresh set of eyes on the issue. Will return when I have more information – just letting you know I didn’t forget about you!

0 Likes

#13

Hi. Problem seems to have occasionally cleared. File open and save dialogs, etc., work correctly sometimes occasionally.

Can’t tell you what has changed, other than maybe a couple of reboots, and a Dell update, which was low-level drivers. Currently running Version 0.62.51 Chromium: 73.0.3683.103 (Official Build) (64-bit) on W10x64 build 17763.

Problem started re-occurring. Rebooting solved it.

Now consistently re-occurring …

1 Like

#14

@martin_l,
Still unsure about what’s causing this. I will very likely file an issue for this so the team can review. I just pinged a few members and I’m hoping to get a response by EoD – if not I will file it and send you the link so you can track it’s progress.

0 Likes