“Desktop url files open as text on a web page”

Description of the issue:
“Desktop url files open incorrectly”
Steps to Reproduce (add as many as necessary): 1. 2. 3.
Double-click a on a *.URL file, Brave opens, but treats the URL file as a text file.
(Brave display the raw text of the file as a web page, rather than execute it.)
NOTE: If I Drag-Drop a URL file onto Brave, it executes correctly.
Actual Result (gifs and screenshots are welcome!):
Expected result:
Link executed
Reproduces how often:
Every time I double-click a *.url file
Operating System and Brave Version(See the About Brave page in the main menu):
Win10 2004
Brave “Version 1.16.68 Chromium: 86.0.4240.111 (Official Build) (64-bit)”
Brave is set in Windows as the default Web browser.
Additional Information:
I noticed this symptom shortly after Brave browser did an auto-update. BUT, I can’t say it caused it.
This may be the same issue as Smorgydorg’s in the comment “Desktop url files open incorrectly” (in this Forum but Closed)
This appears to be a very old issue with Chroimum. See
Chromium Issue 114871

Here is a Fix:

  1. Install .URL Handler Extension
  2. Give this extension access
    a. Go to Brave Extensions
    b. Select “Details” of the “.URL Handler” extension
    c. Enable “Allow access to file URLs”

Comment: Double-clicking URL files works fine in Brave now, but this is a hack and should be fixed inside Chromium itself.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.