Dark Theme Is broken or incomplete?

Description of the issue:
I’ve selected the dark theme but many sections of the UI remain white and are super jarring. I’m not sure if this is a bug, a feature request or a feature!?

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Select Dark theme, recoil in horror as settings and menu’s still burn your eyeballs out!

Actual Result (gifs and screenshots are welcome!):

Note DARK is selected yet the entire page including the normal menu remain blazingly white!

Expected result:
Everything should be dark! At the very least adhere to the system theme (which is dark).

Reproduces how often:
100% of the time

Operating System and Brave Version(See the About Brave page in the main menu):
Version 0.65.121 Chromium: 75.0.3770.100 (Official Build) (64-bit)

Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic

Additional Information:

Do you have kde or something like that?
Sometimes the design breaks, because kde for example has two different themes for gtk and qt. Brave is not qt neither gtk. But perhaps it uses the gtk theme anyway?
You should check your settings again!

My DE is XFCE and since the browser is not adhering to the DE theme this should not be possible that my DE is breaking the browser theme. If the browser adhered to the DE / System theme it would not require an option for light or dark. More so if the browser was adhering to the DE / System theme it would be dark like the rest of my UI which is why the white is so nasty…

I use GNOME 3.x with Adwaita Dark GTK theme (if that matters) Ubuntu 18.04 LTS and I have this same issue. I hav selected “Dark” in Brave colours and “Classic” in themes. It’s a bit frustrating to kill my eyes everytime I have to open the Settings page or any other Brave page for that matter.

1 Like

Can confirm the problem on Manjaro with kde. Have tested the stable and beta release.
I’ve reported it on github as I think that it’s a bug

Using Gnome, dark themes applies to general ui but not menus.

  • Set to use GTK+ theme in Customize -> Settings -> Appearance
  • Close all Brave windows
  • Start with GTK_THEME=Adwaita:dark brave

Can use different themes to test.

That would be what is called broken and incomplete heh. This is also a general gripe about “dark” themes lately that seem to think a black title bar is “dark” while other elements are brutal stark white eye straining nightmares. Menu’s are part of the general UI. DARK == DARK not DARK == “Some bits, some bits not”

Anyhoo I’ve moved on. So many broken webkit based browsers these days there is no point to sticking with those who sit starkly on the more problematic/broken end of the scale. Maybe I’ll check back in a few years though by then Vivaldi will probably be far better an option.

@nPHYN1T3 (and anyone in this thread)
Are you still experiencing this issue after updating to v0.66.99? We pushed a fix for this issue in the update so this should be resolved.

1 Like

@Mattches thanks for looking into it! v0.66.99 is not in the repos yet, newest I have is v0.66.90 … but from the github build of v0.66.99, which I tested today, I can say that it still doesn’t work. I will test it again for you, as soon as it’s in the official repos in the beta/stable stream.

@leon0402,
Are you choosing Same as OS or Dark theme in the Appearance menu? I’ve noticed that sometimes I’ll have to select/reselect the option I want for it to take effect.

@Mattches On Linux there is no “same as OS” option, it’s only on my mac book. On my linux machine I just have “Dark” or “Light” … from experience it usually uses system colors anyways, but as everything should be set to dark, it should make no difference.
Another difference to mac Os is that in brave is set a theme called “Use GTK+” (other option: classic). But this just seems to affect the title bar.

Linux:

Mac os:

I just updated and tried and it is 100% broken still. I switched settings, restarted, still all white. Comically though I switched the use classic to use GTK+ a few times and restarted and while it immediately changes the tab/URL UI area it completely ignores the system/GTK theme everywhere else in the browser.

I have noticed this as well. I was wondering why the settings and context menus were all white on Linux when the dark theme was applied everywhere in Windows.

Same issue on Manjaro KDE Plasma 5.16.3, Brave version 0.66.99

1 Like

Will this ever be updated or remain broken forever? No kidding, this just might be the reason I migrate away from Brave. This seems like something not very difficult to implement as it is already working on Windows and Mac versions. Need a fix (or an update on the issue at least) ASAP.

This isn’t just a Brave thing and it’s not OS-specific. I have this behavior in Chrome, Chromium, and Brave, and in Windows, Linux, and Mac, and even in the latest Nightly build, even using an extension like Dark Night Mode to more extensively theme web pages I visit. Even with a dark theme and Dark Night Mode enabled, settings pages in all three Chromium based browsers I have remain in light mode. I vaguely remember something about the Chromium code forbidding modification of the settings pages as a security measure, and that applies to the color scheme?

EDIT: I tried the Mac version one more time after posting, firing up a vanilla profile in 0.69.44, and the Settings page is dark when Dark is selected and no extension is used, but the version page isn’t and external sites have mixed results (bulk of CNN.com is white though header is black, for example).

It has? I just tried a vanilla profile in Brave Version 0.69.44 Chromium: 75.0.3770.100 (Official Build) nightly (64-bit) on Windows 10 1809 and none of the pages I tried reflected the selected Dark color scheme. Dark Night Mode has been the only thing that works for me.

OK, it does appear to be fixed in same version of Brave on Mac 10.14.5 for the Settings page, but not the version page, and not external pages like cnn.com. EDIT: Mixed result on cnn.com - header and footer are white text on black, rest is black text on white background.

Using version 0.66.100 under Linux.
Still broken with both Classic and GTK Theme.

I checked on Chromium, and it correctly applies GTK theme in menus (screenshot bellow), so this is a Brave browser issue alone, AFAIS.

I use Brave browser on Windows as well and with the 1903 update after setting the theme to dark, it automatically picked it up and everything was dark. I tried switching my theme to light and “Brave colours” to dark and it worked as expected. The native brave pages such as settings and downloads were dark, the menus were dark too. So, I think it should work similarly in Ubuntu too. And as @paulodiovani said in his comment, it’s not a Chromium issue. Devs, please fix this :sob::sob:

1 Like

So in the brave dev build, which is Version 0.69.100 Chromium: 76.0.3809.87 (Official Build) unknown (64-bit) on my system, I finally have a dark theme on the settings, history, booksmarks and downloads page

it doesn’t work on the rewards page though! (neither on the fullscreen page nor on the popup from the adress bar)

And what bothers me a little bit are these scrolling bars! They just look horrible in that dark theme! Could there possibly be a fix for this (Perhaps I would prefer to not have scrolling bars at all! Especially not the one in the middle)