Crypto Wallet Glitch

Description of the issue:
I have set up Brave on multiple PC’s, and on the first PC I used it on, I was able to set up a crypto wallet no problem. Now I know for obvious reasons, the wallets are not synced between devices. On another one of my PC’s, which I am now using more frequently, I went to go set up a crypto wallet, but then I remembered I had to manually type out the secret key, which I didn’t have time to do at the time, so I navigated away from the page. Now I’ve tried to go into the crypto wallet screen again, and try setting up again, only this time I was presented with a screen saying “Welcome Back” and a Enter your password form. Entering any password does cause a loading circle to appear briefly if I enter what I assume would be the correct (or at least the password I would primarily use), and says incorrect if I use any other password. Also there is a link below to click to recover wallet with secret phrase, but clicking it does nothing. There is nothing else on this screen. No forgot password, no Create New Wallet button, nothing. There also doesn’t seem to be any other way either through settings, or the hamburger menu to get to any other Crypto Wallet related page. Every button or link leads to this glitched page.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
0. Perhaps only partially activate crypto wallet, then leave halfway through??

  1. Click “Crypto Wallet” either in settings, or from hamburger menu
  2. Type (supposed) password in.

Actual Result (gifs and screenshots are welcome!):

Expected result:
I’m assuming I should be brought to the "Create Your First Wallet Page

Reproduces how often:
Always

Operating System and Brave Version(See the About Brave page in the main menu):
Windowsb 10 Home - Build 1909 || Brave version 1.0.1
Additional Information: