Cant login to Crypto Wallet

I cant login to my brave browser on the “Crypto Wallets” tab

Windows 10

i enter my password and it just returns to this screen

no message indicating that i have entered the wrong password

Try closing out all Brave-related processes, restart the browser, and try again. Make sure you get your password right on your first try, otherwise you’ll be locked out.

I have gone as far as reinstalling the browser. How do i reset my password, there is no option to do that on the landing page?

Iv’e got the same issue. It has never worked. I even recovered it successfully and has never let me log in. When you select “import using account seed” it just sits there when you click it. I have double checked my password a million times. I even “restored” my wallet in the rewards tab and it STILL has never let me log in. Now I am trying to use my Metamask extension and it asks me to log in to Brave crypto wallet first. Then I can log in to Metamask with a different password that looks a lot like Braves. I believe it is not allowing me to use my Metamask on platformes like BZX and 0x new portal.

I need help with this ASAP please!

1 Like

Crypto Wallet passwords can’t be reset, unfortunately. Not even Brave can restore it for you @Bobwood.

@Mattches can you take a look at @KryptoKell76’s post and help them disable Crypto Wallets so they can use Metamask?

Tagging @ryanml here on the Crypto Wallets team to take a look as well.

1 Like

@Bobwood, @KryptoKell76, would either of you be willing to send me your profile for diagnosis? You can do so at rlanese at I completely understand if you would prefer not to. There’s other steps I can share with you to further debug.

Can you both please navigate to brave://components in your browsers and let me know what version number you see for Crypto Wallets?

Yeah I’ll send you my account… Don’t know what that means or how to do it but tell me what you need and I’ll do it. This has been a problem for a while now.

Thanks for the reply. I don’t know if it needs to be reset or if there is a different problem. It has never worked. So I am really confused.

Went to components and it says this :

Version: 1.0.15

Status - Component not updated

I am having the exact same issue ever since I started using Brave.

  1. Password never works. It never even says anything failed. It just clears out and resets in the blink of an eye.

  2. If I try to click on “Import using account seed phrase” the word “Password” in grey just drops down into the password line as a larger size, then bounces back up to it’s small version again and nothing changes. No chance to type in my seed phrase.

Hi @hugginsjl and all, we issue an update today that resolves these password login issues. Please see for details. Thanks!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.