Crypto Wallet extension in wrong language (japanese)

Description of the issue:
How can this issue be reproduced?

  1. The crypto wallet extension is not in English
  2. Open it?
  3. Changing the language in settings, uninstalling and reinstalling, nothing has worked so far

Expected result:
for it to display in english

Brave Version( check About Brave):

Version 1.26.74 Chromium: 91.0.4472.124 (Official Build) (64-bit)

Additional Information:
Acer laptop running Windows 10

I am having the same issue, but display language is Chinese. I have removed all other display languages from the Advanced Settings, except for English.

Hey @satisfiend !

Can you please update your browser to see if the issue persists?

Thank you,


It’s up to date, same problem as when I posted

It might be based on your system’s location; can you try changing the region it is set to then uninstall and reinstall the extension?


The system region has always been United States. I see no options for region settings in the brave browser so I just tried removing all additional languages from the system. I’ll try uninstalling and reinstalling after I get my tabs saved. I thought brave sync was supposed to let me share tabs between pc and mobile but it’s never let me do that.

Uninstall/reinstall worked. But kind of an annoying fix.

Uninstalling didn’t do it

I had to do it twice - it didn’t work when I kept the browsing data
Hope that works for you

I’ll try that now thanks

Computer crashed after uninstall/reinstall… Still stuck on boot logo

Got it reinstalled lost the bat rewards I had built up for the month though…lousy way to fix a small problem that should be fixed by dev team

And lost all my bookmarks. What was the point of linking to my mobile browser if I was gonna lose my rewards and bookmarks…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.