Crunchy roll log in not working on brave

Description of the issue:
Cannot log into crunchy roll on brave and when I ask for an email to reset password it never comes. But when I go onto google chrome and log in with the exact same details it works. have tried clearing browsing data

Did the issue present with default Shields settings? (yes/no)
Does the site function as expected when Shields are turned off?
Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
Does the site work as expected when using Chrome?
**Brave version:

Version 1.52.130 Chromium: 114.0.5735.198 (Official Build) (64-bit)

1 Like

I’m able to login to Crunchyroll without any issues. Can you try logging in with Shields down and tell me if you are able to do so successfully?

If not, can you please try opening the dev tools console window (Menu --> More Tools --> Dev tools --> [Console tab]), then try logging into Crunchyroll and after it fails, share any output from the console window with me here?

Thank you

dg.js:1 Evidon: DG: Script Environment: PROD
dg.js:1 Evidon: DG: CompanyId: 2796 / Company Config: Object
dg.js:1 Evidon: DG: SiteId: 01981772 / Site Config: Object
dg.js:1 Evidon: DG: Loaded country.js (sync): Object
dg.js:1 Evidon: DG: Loaded siteConsentGeo.json (sync): Object
dg.js:1 Evidon: DG: Browser is GPC enabled:true
dg.js:1 Evidon: DG: Searching For ConsentGeo Settings For CountryId: 48 (nz) / StateId: undefined (undefined)
dg.js:1 Evidon: DG: ConsentGeo Match NOT Found. Using DEFAULT UCP Consent Setting
dg.js:1 Evidon: DG: Loading ConsentControl [pid: 16] (sync)
dg.js:1 Evidon: ConsentControl: Config: Object
dg.js:1 Evidon: ConsentControl: Searching For ConsentGeo Settings For CountryId: 48 (nz) / StateId: undefined (undefined)
dg.js:1 Evidon: ConsentControl: ConsentGeo Match NOT Found. Using DEFAULT UCP Consent Setting
dg.js:1 Evidon: ConsentControl: GeoConsentType = 1 [Opt-In (GDPR)] | ConsentControl Enabled = true
dg.js:1 Evidon: ConsentControl: Consent NOT Found: Enabled / Blocking
dg.js:1 Evidon: ConsentControl: Random (10) Within Bounds of CollectionPercent (100) - Report Violations Enabled
dg.js:1 Evidon: ConsentControl: reloadOnCookieFound = true / reloadIntervalMs = 2500
dg.js:1 Evidon: DG: Loading GranularConsentControl [pid: 19] (sync)
dg.js:1 Evidon: GranularConsentControl: Yielding to ConsentControl
dg.js:1 Evidon: DG: Loading TagControlV2 [pid: 16] (sync)
dg.js:1 Evidon: TagControlV2: Yielding to ConsentControl
dg.js:1 Evidon: DG: Loading Observe [pid: 18] (async)
dg.js:1 Evidon: DG: Product Script Loading Complete: Consent Control, Granular Consent Control, Tag Control v2, Observe
dg.js:1 Evidon: DG: ConsentControl: BLOCKED Resource: https://undefinedsnowz5ozqgjez6dovhmyvab0gcznw5n9/analytics.min.js
dg.js:1 Evidon: Observe: Config: Object
dg.js:1 Evidon: Observe: Random (60) Within Bounds of CollectionPercent (100) - Observe Enabled
evidon-sitenotice-tag.js:1 Evidon – evidon-notice-link not found on page, cant display the consent link.
dg.js:1 Evidon: DG: UCP Notice Id: 87393
dg.js:1 Evidon: Observe: [Scan 1] Collecting: Array(31)
dg.js:1 Evidon: Observe: [Scan 2] Collecting: No New Resources Found
dg.js:1 Evidon: Observe: [Scan 3] Collecting: No New Resources Found

Its looking at your location, are you using a VPN?

Not using a vpn but I have used a vpn in the past

Maybe the cookie set orginally was for a different country? Try clearing the cookies for crunchyroll and re-login? Possibilty also that the login is tied to a certain location, but I don’t know for sure.

1 Like

If it was a location issue would it not work on google chrome as well? I tried clearing cookies for crunchy roll but no fix

Does it work in private window mode?

yes it does seem to work in private window

1 Like

Try normal mode, no extensions enabled

yup disabling all extensions worked

Which extension is causing it? disable each one until it fixes it.

none of them by the looks I just turned them all back on and it works maybe turning them off and on fixed it?

Out of interest, which extensions is installed if you don’t mind me asking

just google translate, phantom crypto wallet and metamask crypto wallet

I’ve tried what was stated here in the timeline and disabling extensions didnt work any other solutions?

What issue are you having? video playback?

The website works without using an account, but I can’t login nor change my password

After trying some of the earlier solutions and establishing a baseline: disabling extensions, clearing all cookies, allowing 3rd party cookies, and having shields down, I’ve noticed that I can sign in the first time to my account.

Now if I sign out and attempt to log back into Crunchyroll, it’ll prompt me with a “something went wrong” error and I’d have to clear cookies again just to log back in.

1 Like

Similar issues with Crunchyroll.

Brave 1.56.11 Chromium 115.0.5790.102 64 bit; Windows 10 22H2 19045.3208.

Experienced no issues with Crunchyroll up until about 1 AM Sunday the 23rd. Watched some episodes before work, came home, Crunchyroll was logged out. I now experience the same problems as others have shared here. An attempt to login simply doesn’t do anything besides load for about 15 seconds, then produce an error message containing nothing more than “Something went wrong” from the website.

Login is successful if attempted in Edge, Chrome, or private mode on Brave. Turning off shields, disabling all extensions, and clearing all cookies and cache does not yield a successful login in “normal” Brave browser mode. Installed extensions are Canvas Blocker, Search by Image, Sites Dimmer, SponsorBlock, Tampermonkey, uMatrix. Most of these are also present in private mode where login is successful.