Website doesn't let me login even with shields off

bug

#1

When trying to login to www.SongFreedom.com, I enter my username and password, but when I click “sign in” I’m prompted to enter a valid email.

  1. Go to www.songfreedom.com
  2. Click sign in
  3. Enter my username and password
  4. Click sign in39%20AM

This happens every time and in a previous version of Brave as well. I’m able to sign in with Chrome, Firefox, etc without any issues.

Version 0.56.15 Chromium: 70.0.3538.110 (Official Build) (64-bit)

**Reproducible on current live release (yes/no): yes


#2

@Cakewalk,
Click on the “lock” icon on the left-hand side of the address bar: image

Is there anything listed as “blocked” in the drop down that appears?


#3

I just checked and nothing is listed as blocked.

It shows:

Connection is secure

Certificate (valid)

Cookies (10 in use)

Under Site Settings, everything is set to the default settings. The Block (default) are:

Flash

Pop-ups and redirects

Ads

Autoplay

Larry


#4

Two things to try:

  1. Try changing your Global Shields default to Allow all cookies


    Then try to log in. If this works, once logged in, you should be able to reset your Global cookies settings back to what it was originally.

  2. If the above doesn’t work, try navigating to
    Settings --> Advanced --> Privacy and Security --> Content Settings --> Cookies
    From there, click the Add button under Allow and enter the sites URL in this format:


#5

Sorry…neither worked…

Larry


#6

Unfortunately I’m unable to check this myself since I don’t have an account. I’ll have to ask around about this.
In the meantime, try to sign in using a Private Window and let me know if you’re get the same error.


#7

Hi,

I emailed them about the problem and how their site doesn’t work with Brave. Here’s the response I got (it might have come from their CTO - not sure):

"Please tell him that our site’s frontend is a Javascript app written in Angular (by Google). The Angular developer team has a browser compatibility page, but it does not list the “Brave” browser. If Larry has a contact at Brave, he can instruct them to work with the Angular team to ensure their browser is fully compatible. After the Angular team signs off on a browser, then we can start to look into it. "

Larry


#8

Hi,

I also heard from someone else in SongFreedom’s tech support group. They suggested the reason I was getting that error was because I was trying to login with a mixed case username. They suggested I try all lower and that worked. I haven’t done any coding for a few years, but I’m somewhat mystified that case (still) makes a difference in a logon process.

Larry


#9

Certain companies employ “case sensitive” authentication techniques as it increases security (or at least makes it hard to crack someones credentials). Google, for example, is not case sensitive but many institutions like banks or universities will require credentials to be formatted this way.

Glad you got your issue resolved. I’ll go ahead and lose this thread now but please don’t hesitate to reach out and create a new post if you have any additional questions.