Brave release constantly crashing on Mac OSX 10.14 - Macbook Pro 13" 2016

Hi Brave Team,
I am not a tech guy, but I’m going to try to explain my issue as detailed as possible.
When I was installing Brave release for the first time, it was stable and no issues. After uninstalling it and reinstalling for a second time (same release version), it is not possible to open Brave anymore. It crashes constantly while the Brave icon is bouncing in my dock for the starting process and gives me the following message:

Opening the report, it tells me the following:

36

If you’d like to, I can send you a log file, as it happens every time.
I was curious and tried the current beta version - same issue.
After that while looking for a solution, I randomly found another Version called Brave-0.25.2.dmg. Thatone works perfectly, but tells me it will only work for 10 days.

So is it my fault or is there an issue with Brave? I’m starting to dispair… :confused:

Thanks a lot for your awsome work! That is a browser concept I was dreaming of a long time, that’s why I really would like to have that issue fixed :slight_smile:
Alex

PS: If you need further information, please let me know.

@djrelord,
Thanks for reaching out. Lets see if we can get to the bottom of this.

First, open Finder and navigate to ~Users/YourUserName/Library/"Application Support"/. You should see a BraveSoftware folder located here ( additionally, since you mentioned it, you should see a brave folder here too – this contains data for the old installation you found, v0.25.2).

If you don’t see one then we’ve already found the issue! Reply and let me know if that’s the case.
If you do see the BraveSoftware folder there, open it and take a screenshot of anything inside this folder and share it here.

@Mattches ,

thanks a lot for your fast reply. Yes, I do have that folder, but it’s completely empty. What should be inside? How do I progress now?

One thing to note: when uninstalling an app, I always use an App Cleaner tool, to get rid of redundant data and folders. So did I after uninstalling for a few times now. Could that be an issue?

Alex

I’m going to take a guess and say new Brave is having a conniption because there’s a BraveSoftware folder and no Brave-Browser folder inside it like this (ignore the Beta, Dev, and Nightly folders - I have all four installed):
image

Probably don’t do anything until @Mattches replies, but I’m thinking delete the BraveSoftware folder and try Brave 63.55 again (or add a Brave-Browser folder inside BraveSoftware - this is why probably wait for Mattches).

Best of luck.

1 Like

@djrelord,
Thanks for the info! Definitely as I suspected. For some reason the profile folder was never created so when Brave launches and tries to find settings to load it fails (since there aren’t any!).
@hnktong – great suggestions and support! I’m actually not entirely sure which method is the most reliable but I do know that this (has been) an easy fix. @djrelord, try the following:

  • Create a new folder inside BraveSoftware titled Brave-Browser@hnktong’s image above shows the folder for reference. Now launch Brave; ideally, Brave will detect that there is an appropriate directory there and load it with browser defaults.
  • If the above didn’t work, try deleting the BraveSoftware folder entirely and launch Brave; the idea is the same as the first suggestion here.
  • If nether of the above work:
    1. Trash the BraveSoftware folder (and the brave folder while you’re at it, unless you need it for something)
    2. Trash any Brave.app files
    3. Remove any Brave icons from the dock.
    4. Re-download and install Brave

Let me know if this resolves the issue for you.

I think the empty BraveSoftware folder was left by @djrelord’s app cleaner.

1 Like

:point_up: Yep, that’s almost too obvious :stuck_out_tongue:
Good catch @hnktong.

@Mattches @hnktong

Sorry for the late reply, i was a bit busy over the weekend. Thanks al lot guys for your support, it worked by just creating the “Brave-Browser” Folder.
I’ll get back to that thread commenting if it really fixed the issue and it works stable after a few days.

Alex :slight_smile:

2 Likes

Thank you guys for your help, brave seems to be stable and i keep on enjoying :slight_smile:
Alex

2 Likes