Close the current tab: Ctrl + w not working

Description of the issue:
Common shortcut/hotkey for closing a tab doesn’t work (Ctrl+w).

There’s a list of info here saying that there are 2 shortcuts for this action:

Close the current tab Ctrl + w or Ctrl + F4

But only Ctrl+F4 works, which is not so convenient for productive browsing.

Expected result:
I’d like to have Ctrl+w shortcut working in Brave on Windows.

Operating System and Brave Version(See the About Brave page in the main menu):
OS: Windows10Pro
Brave: v1.62.162 (Feb 7, 2024) Chromium 121.0.6167.164 - updated to currently latest version.

Additional Information:
Other commonly used shortcuts related to tabs, e.g. switching, closing, re-opening last closed work normally.
I use also Brave on Ubuntu 22.04 LTS and don’t have this issue. Ctrl+w works there normally.

Previous time I posted this topic, the shortcut started working out of the blue, so I responded and the thread has been closed automatically. Now the shortcut still doesn’t (since that time I haven’t use Brave on Windows, apparently the problem persists). I tried to assign the key combination and noticed that when I push it takes either W or Control button, but doesn’t recognized them pushed at the same time. There’s no such issue with other combinations like Control+Q. I think it’s a hint to what’s wrong, why ctrl+w doesn’t work. Hoping for a solution.


@leo1,
First, can you please update the browser to the latest build (1.64.116) and tell me if the issue persists?

@Mattches Thank You for your reply!

Brave About tab says:
Brave is up to date
Version 1.64.122 Chromium: 123.0.6312.122 (Official Build) (64-bit)

@leo1,
Just saw your original thread as well. Honestly not sure what’s going on here — do you have any other software on your machine that could be hijacking the key combination?

I’d also be curious to know if using the Ctrl + W shortcut in other browsers closes tabs?

Wanted to reply since I just found this thread while searching - in my case it was Samsung Magician causing the issue. Closing Magician from the tray restored normal functionality. This happened a few months ago, and was resolved for me previously after an update, but appears to be affecting some users again. Definitely try updating Samsung Magician if it’s installed and see if that resolves it.

Windows Update KB5034123 or enabling Gaming Mode can also cause some key combos to stop working.

Hope this helps!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.