Change language for spelling correction

Has changed the language to Norwegian, and works perfect except one thing:
Whatever I try to do, Brave insist on using English spell correction.

can confirm, i normally use english + portuguese and so far its only checking for english words

edit : actually, i enabled portuguese as a second language and pressed ok , then if u go back to the settings u can enable a toggle for spell checking in the recent added new languange. i just did it.