Certain Websites Not Working on Brave Browser

Hi, so I wanted to watch a movie on HBO Max on my Mac, and I opened it on Brave since that’s the browser I use these days. However, on every movie and TV show I clicked on, I got the something went wrong error with the Help Center URL only leading to a page with a few lines of code and a message saying “This XML file does not appear to have any style information associated with it. The document tree is shown below.” I’ve disabled all my ad-blocking extensions on the website, disabled Shields, done a hard refresh, updated Brave to the latest version (Version 1.58.131 Chromium: 117.0.5938.92 (Official Build) (x86_64)), updated my MacBook to the latest version (macOS Ventura 13.6) and restarted my device today. I tried the Video Playback Quality command flag as well but it seems like it was removed from Brave in a previous update. These errors also appear on Private Browsing as well. However, this works on Chrome and Safari even with ad-blocking extensions enabled, and the app on my phone is perfectly functional, having been updated to the latest version. The same goes for Amazon Prime Video, the other website I watch streaming content on. When I try to watch something there, I get a “Digital Rights Error” saying that my browser is missing a digital rights component. Is Brave just not a supported browser for any of these websites or is there something that can be done?

Is widevine enabled in brave://settings/extensions ? (or try disabling/re-enabling).

I enabled it and it worked, thanks for the help.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.