Certain Home Screen Causes 4k Curved Monitor to Flicker

Description of the issue:
This is a weird one. There is something in this home screen page that causes my monitor to flicker (for lack of a better word). I see pulsating vertical lines flickering rapidly as if the monitors are refreshing either too fast or too slowly. It reminds me of the flicker you’d see when recording monitors with slow FPS in older cameras or monitors.

This one is really weird, it doesn’t seem to happen on both monitors (though both monitors are not same model and the other one is in portrait), or on the laptop screen itself. Only seems to show up on my curved 4k screen. Only seems to happen when the window size is taking up a large portion of the screen. If I make the window smaller is seems to stop. If I make the window full screen it stops. If I click on the hamburger menu in Brave it stops. It causes the whole monitor to flicker, not just the area this window is displayed.

The MacBook this is happening on is my 2021 MacBook Pro with M1 chip.

How can this issue be reproduced?

  1. Keep starting a new tab (with home page) until you land on the one I mentioned.
  2. Expand the Brave window to take up a large portion of the screen.

Expected result:

The screen does not flicker when displaying anything in the browser.

Brave Version( check About Brave):

Version 1.48.158 Chromium: 110.0.5481.77 (Official Build) (arm64)

Additional Information:
This seems very similar to an issue that used to happen with IntelliJ (maybe the new UI version) and would happen on all my M1 MacBooks. I believe that would happen when an inactive IntelliJ window had things moving in it, but that was a while back and the issue was resolve with subsequent versions.

The flicker can not be seen in the screen video recording I took. I tried taking some video with phone but its hard to see. Let me know if/how I can provide that if necessary.

I found another Brave home screen that at first didn’t seem to cause it but when I started scrolling up and down it seemed to start happening… Then I just made the window bigger and it started happening with or without scrolling.

Also, I did flipped my other 4k monitor down to landscape and tested this and it didn’t flicker. Not sure if this has anything to do with the monitor being curved as to what would cause the flicker.

Hello @jbcuningham, thank you for reaching us out. By any chance do you use extensions? Does the same happen in a private window? in case it does not work, can you try disabling the following: Settings --> System --> Hardware Acceleration Let us know if that fixes the issue. Regards.

@Jarc-1107 - No extensions. Yes it happens in Private. In private it happens with the window taking up almost the whole screen, as well as in fullscreen (which isn’t the case with the other background).

I tried disabling hardware acceleration but this didn’t fix anything. It did however make scrolling on the homepage really jittery and slow.

Hello again @jbcuningham, please try with the following: Open the Terminal and enter this command: open -a "Brave browser.app" --args --disable-gpu or going to brave://flags > Search 'Vulkan' > Disable Vulkan > Retest

Sorry I forgot to reply, I wanted to take a day or two to try this. I wasn’t able to ever get those background images to show up at all… I’m not sure if they were removed but I don’t see them at all anymore. So I can’t tell if this fixed anything.

Sounds good, let us know in case the issue persists. Regards.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.