Can't update Brave using BraveBrowserStandaloneSetup.exe

My connection is so unreliable that it’s very difficult for Brave to auto-update, because it frequently gets interrupted and restarts the download from the beginning, so I downloaded the current release version, 1.28.106, of BraveBrowserStandaloneSetup.exe from Github. Unfortunately, it seems to immediately exit without installing the new version of Brave. Do I need to uninstall the old version of Brave before the installer will run?

No, you don’t need to do an uninstall first.

Do you literally mean it exits immediately, or is there any sort of “final message” at all before it does so?

It exits immediately. There are no messages of any kind. I tried this on two Windows 10 computers. I exited Brave, double-clicked on BraveBrowserStandaloneSetup.exe in File Explorer, and saw the spinning circle briefly, but saw no messages or anything else before the spinning circle stopped. I couldn’t find the installer in Task Manager either.

I have since been able to upgrade Brave on both computers through the usual method. I tried out what I did above on one of them again (even though it now has the same version of Brave that the installer would install) and could now see that the installer does appear for a few seconds in Task Manager, then disappears.

OK. Yeah that seems strange. I have had a few instances where the installer dialogue would appear behind other windows, so I thought it hadn’t started until I saw it in the Windows Taskbar. But doesn’t sound the same as what you saw.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.