Can't Re-authorize brave rewards to uphold

Good day! I’ve been having this problem for a long time now, I can’t seem to re-authorize my brave rewards to my uphold account. The app always showing this error.

Both my brave browser and uphold app are updated from the playstore.

Try this.
Disable Uphold defaults (opening links & in android.
Rerun the verification process and complete it through a browser.

Now it shows this

Next step, I would do, unlink Brave Browser from Uphold and try again or wait for a more expert than me.
There is a case where you might be affected. It’s a similar problem, isn’t it?

1 Like

I tried this but doesn’t work either.

I also tried to turn off the brave shield.

Hi, you might want to remove your wallet payment id. Brave support recommends you not post that information.

Other information and things you might try:

  1. Users from Vietnam, Philippines, and Turkey are not able to connect to custodial providers at this time.
  2. Clear history/cache, exit Brave, and reopen. This works for some users.
  3. Make sure your jurisdiction is still supported by Uphold: Uphold Non-Supported Jurisdictions.

That’s all I can think of atm. If I run across anything else, I’ll post an update!

I did try this just a sec ago, tried to clear all browsing history and cache but nothing happened.

When you edit a post, everyone can see what the original post was and what was changed. Since your wallet info was in the original post, I suggest you delete the thread and repost without the wallet info.

1 Like

@BulokIPbannedISBACK I don’t understand… I posted an off-topic comment in another post but it was directed to the person who created the topic and who initiated the off-topic content. Figured it was their topic and we were the only two posters, so no harm, no foul. This is definitely a different situation.

Please create a topic in the appropriate category (Community Feedback? Uncategorized? Misc?) and we can continue this discussion if you like. Continuing here will get our posts flagged. Tag me if you want to make sure I see your post.

Apologies to the OP for the off-topic post.

@arcturusvoid Well, I think all the typical reasons most users receive this message and the things to check have been addressed. Listed a couple other things you might check. Doubt these are the issue if you have been able to connect in the past.

  1. Brave and OS are updated to the latest version.
  2. Does your device pass the SafetyNet check?
  3. Try disconnecting from Uphold, turning rewards off, clearing history/cache, exiting the browser, and then reopen browser, turn rewards on, connect to Uphold via the website (follow the instructions above again). This is called grasping at straws. :wink:
  4. Try rebooting your device? Not sure about this one on an Android. I use windows and can reboot at will with no consequences. Not sure if that action is comparable on an Android device.

Didn’t ask specifically before, but you have been able to connect to Uphold in the past and you have received payouts previously, correct? And… what does your External Wallet Info/Wallet status display at brave://rewards-internals?

1 Like
  1. Yes, my OS and Brave App are both updated to the latest.
  2. Yes, my device did pass the SafetyNet app.
  3. I did try this and got the same result
  4. My problem has been around for like weeks now (4 weeks I think). I’m pretty sure that my device has been rebooted many times.

Yes I did connect my device to my uphold before and got my payout as well.
In external status it shows: Wallet status: Not connected.

I think you’ve tried it all! Sheesh. So sorry nothing worked. :slightly_frowning_face:

I think the only thing left is for you to submit a support request here: Submit Request.
Include all the details you can! I would also include a link to this post.

You could also DM the moderators with your wallet payment id at brave://rewards-internals. They may have more information, especially about any Brave GitHub issue reports that may be open. Let me know if you need more info on how to DM moderators.

Please post an update if you find out anything. I do hope your issue is resolved. Good luck and take care! :smiley:

1 Like

Thank you for your concern! I would just file a request to admins.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.