Can't play Udemy videos

Description of the issue:

Impossible to play a course on Udemy. Preview of the courses works fine, but not the course itself. It did previously worked (few… weeks ago. I haven’t been that serious with Udemy lately)

How can this issue be reproduced?

  1. Go to a course on Udemy and try to play the video

Expected result:
Video will not play. A pop-up will appear from Udemy.

Brave Version( check About Brave):
1.21.76

Additional Information:

Of course, I tried disabling Brave Shield, uBlock Origin, Privacy Badger and AutoplayStopper. When using Safari, it works perfectly, so it’s not my network neither.

2 Likes

Hi, if possible you can PM login details, I can check it out. Could try in private window mode, or a new profile.

It’s not just you, I’m having the same issue. Videos play just fine in Chrome or Safari, but now they no longer work in Brave.

I just test this, can you test in a clean Brave beta profile?

I created a new profile and logged back into Udemy. When I tried playing a video, I got a popup asking me to enable Widevine (some sort of DRM protection). I clicked on yes and now the videos are playing. Went back into my normal user profile and videos are playing on there now too. Guess that must have been what was causing the problems

1 Like

Great to hear, thanks for confirming @robmcguire

Thanks @robmcguire! I did that too and now it’s also working. So, the solution is to create a new profile and log in to Udemy. Then, Udemy will ask to install a Google DRM (Widevine). Then, you’ll be able to login using your regular profile.

May I suggest that Brave offer to install that extension in the current profile in a next update? For me, it’s solved, but for other users…

Thanks again @fanboynz for your time. The issue was that f***ing DRM.

1 Like

Great to see it working @lokan

1 Like

would be nice if we could allow only on specific sites.

Thanks for the tip.
I really wish the browser didn’t have these many restrictions in normal sites.
So far I’ve faced the issue of the video not playing in almost all the sites I visit, YouTube, Udemy, edX, to name some.
While I was using Chrome, the videos played fine. But when I switched to Brave, I have to keep finding workarounds like this in order for the video to just play. I really don’t want to CREATE another Udemy account just to make a video PLAY.
I hope they fix this soon.

No changes by Brave regarding Udemy, Udemy changed the site to require Widevine.

I’m not aware of any issues with edX, but would need more info. Free to PM, Twitter/Telegram with more details.

I have the same issue as of recently (April 2021). I think Brave could be improved so that if Widevine is now required for playback it would prompt for it. Creating a new account just to load a new course and get the prompt is pretty hacky and I’m not sure it’s totally effective. I just tried it with a new profile and free course and it didn’t work.

I loaded several of my Udemy courses with my main profile and some loaded, but I can’t tell what the failed ones have in common. It seems fairly random. Some courses load consistently, others don’t.

Jeremy

I had the same issue and I found another site with a solution to this. Go to settings in Brave. From the top right search for “DRM”. There’s a section to enable Widevine.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.