Can't play Udemy videos with Brave

Description of the issue: Can’t play Udemy videos

I’m able to watch my Udemy videos using Safari, but I’m encountering difficulties when trying to do so with Brave. Despite trying various troubleshooting steps, including resetting settings, allowing all cookies, disabling shields for Udemy, trying a different Brave profile, toggling Widevine on and off, and using a private window, the issue persists. Interestingly, I don’t encounter any problems when using Safari; the videos play smoothly without any delays. However, when I attempt to play the same videos on Brave, they continuously load without ever starting playback.

Brave Version: 1.62.162 on MacOS

Additional Information: i have read and tried everything posted on the community

Does it never show any messages or anything? In fact, can you show a video or screenshots of what you see?

Which Mac OS are you using?

Those are completely different browsers, it would be more relavent to try to test using a chromium based browser. Could you perhaps test to see if it works on Chrome? Also, might want to test on Brave Beta or Brave Nightly to see if the issue persists on them.

Things I’m not seeing and also will suggest and/or confirm:

  • When you did new profile, did you do it with no extensions and everything at default? (I want to make sure you didn’t change anything on new profile)

  • Disable hardware acceleration in SettingsSystem

  • Make sure you haven’t changed any flags at brave://flags

  • When the video isn’t loading, can you press Cmd+Option+J to open Dev Tools and check Console for any errors. This is especially the case when Shields are down and it’s not playing. (With Shields up, it will show errors for anything being blocked, so can be a big list)

1 Like

Monterey 12.7.3 on mac pro mid 2015

I actually tried those as well, but they did not work.

@Saoiray these are the steps provided by GPT and interestingly, i have done all of them!

  1. Clear browser cache and cookies.
  2. Update Brave to the latest version.
  3. Disable browser extensions.
  4. Check Brave settings.
  5. Reset Brave settings…

and yes it worked perfectly fine on chrome!

@Fanboynz anything you can think of to test or change?

1 Like

Would test disabling/re-enabling Widevine in brave://settings/extensions

They mentioned doing that on original post. But let me tag @roozbehr72 to confirm did so through Brave and was not using extension or whatever.

1 Like

already did it! not once :slight_smile:

Frankly speaking, NO! im confused. i even tried safe boot. any suggestion based on the screenshot i uploaded?

@Saoiray, in the end, I had to uninstall brave completely and reinstall brave-browser.dmg again, and the problem is solved for now! Thanks in advance.

1 Like

That’s really weird. Kind of curious what went screwy. But at least glad to know you got it fixed.