Udemy videos not playing

Whenever I try to play a video/lesson from Udemy the video screen just stays loading forever. I have attempted to play with shields up and down.

I have posted a link to what I keep seeing in to the developer console over and over again. The video doesn’t seem to have a problem playing in Chrome or Firefox though.

https://i.imgur.com/LsjstkB.png

@Mizex,
Thanks for reaching out. Can I see a screenshot of the video loading “infinitely” as its displayed on your end?

Here you go, when I press play this is all I get. It will just spin forever.

https://i.imgur.com/pNtQjIq.png

@Mizex,
Interesting – videos seem to work without issue on my end. That said, I’m just using a free sample video since I haven’t purchased any courses so there may be a difference in the type of player (this is why I asked to see what yours looked like):


:point_up: I also apologize for the wonky ending image – screen capture software did not like the video going fullscreen.

Also note that my Shields (set to defaults) were up throughout the process. Would you mind trying to stream content on the site while using a Private window?

Interesting, so I did what you did and it plays just fine when it is the preview videos. It seems to only be happening on the purchased lessons.

EDIT: I was able to get the previews working with and without a private window and I also have shields set to default.

1 Like

@Mizex,
I feel silly for not asking earlier cause it’s usually the first thing if not given – what OS are you using? I have some weird results:

macOS – Everything works great, even with Shields up and viewing purchased content:

Windows 10 – Windows gave some weird behavior. When I first logged in and tried (before recording, of course) the video would not play and would spin in a circle as you described. Shields down, video would play though.

When testing individual protections, I found that changing Cookie control to Allow all also allowed content to be played. However, after enabling Block 3rd Party Cookies again on the site – Shields up – the site will now play without issue every time:

Digging into this a little more but there’s probably a “one-time check” of some kind happening where the site is looking for or looking to place some cookie that’s getting blocked. Either way, try allowing all cookies on the site and see if that fixes the issue. If so, try setting Shields back to their original settings and let me know what happens.

@Mattches, I am running Windows 10 on all the machines that were having the problem. It looks like switching the cookies to allow all briefly and then back as you did also fixed it for me.

I am curious though cause when I had shields up and I switched that very setting in the quick menu like the image shown below that didn’t work. I had to go into the main settings of Brave and switch allow all there. Are the settings not shared or was it just acting wonky?

Either way thank you very much! It looks like my issue is resolved!

@Mizex,
Glad you got this working.

Difference between Global and Site-specific Shields settings can be read here. This has actually happened before but I’m not actually sure why it’s happening now. It was acting wonky, as it were. Allowing all cookies on the site in Shields panel should have fixed this – note that I only changed the setting in the Shields panel to resolve the issue.

Thank you for telling me about this as it may point to a separate or related issue that needs to be addressed. I’ll make sure devs take a look.