Can't log into Twitch

  1. Can’t log into Twitch. At log in it just gives error " That password was incorrect. Please try again.

Can log in with other Browser (Chrome).

Expected result:
Log in

Brave Version( check About Brave):

Worked fine until I installed update last night. Is this a known problem or am I going to have to use Chrome again :stuck_out_tongue:

1 Like

1.45.118 just came out, can you upgrade and see if the issue continues?

If it does continue, are you using any extensions?

How are you entering the password? Copying out of a password manager and then pasting? Typing by hand?

Just updated. Same problem.

Continues with all extensions disabled.

Doesn’t matter whether password manager is used or I type (tried both), same result. Can log in thru Chrome fine.

I just created an account and logged into it with no issues.

Have you tried changing Shields settings for the site? (Mine are at defaults – not the ‘aggressive’ setings,)

If you go to brave://settings/shields/filters and ‘Show full list,’ is anything checked there? Or, anything populated into either of the ‘Custom’ sections?

Yep. Turned shields off entirely on it.

Nothing checked on that page.

I may have to just delete and reinstall.

You can try that, but there might be a few other things you can more easily try first.

Does the issue occur if you create a new profile and try it in that profile? (Make sure your original profile does not have any open windows; only the new profile should be open.)

Also, some other threads (references below) seem to indicate that clearing cookies for the site, or perhaps more thoroughly, using ‘Reset settings,’ might solve the issue. Seems this has affected some random folks.

There’s quite a bit here but peruse if you like:

Based on a quick read thru some of those it looks like you have good odds of getting past it if you ‘Reset settings.’

THANK YOU!!! The reset settings finally fixed it! No idea what was bugged as I really thought cookie clearing would have fixed.

Thank you again!!!


This happened to me again, after a couple weeks of working fine. A reset settings has fixed it, of course that has ruined all the work I did configuring all my websites to suit my preferences and styles. Combined with brave deciding to flag me for possible ad abuse(?!?), this is becoming quite the hassle!

Yep…Not looking forward to fixing everything again, but it’s too late now.

If you don’t mind, what were your Shields settings set to originally (when you were having issues)?

There are some folks in the GitHub issue who say that turning Shields ON (I guess they initially had them off), plus clearing the site cookies, resolved it. I guess if it does happen again for someone, it may be worth at least trying that (or toggling Off and then On, if already enabled) first as it would be less disruptive than the full Reset Settings. And perhaps also try increasing the individual Shields settings, even if escalating them seems counter-intuitive.

Just at the default settings.

While fully resetting settings fixed the issue, next time I would try clearing only data first before doing the full data reset (to avoid having to reconfigure everything).

That was one of the first things I did before even posting.

Worth checking just in case. Will forward this to the team to review but it does appear to be profile related. If this happens again, please try @JimB1’s suggestion above and try creating a new browser profile and see if you get the same behavior there.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.