Can't log into T-Mobile

Description of the issue:

When I attempt to log into my t-mobile account, I consistently get a message that says “Service Unavailable. F451 : Uh-oh, it looks like we have our wires crossed. Please try again later.”

To try again, I have to completely close that tab and start over.
This happens both when Shields are up OR down.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Usual login procedures.
I also tried with Chrome v108.0.5359.98 (Official Build) (64-bit) and Firefox v107.0 (64-bit). The problem does NOT occur with either of these browsers.

**Actual Result (gifs and screenshots are welcome!):sparkles:

Expected result:
Able to enter into my account information.

Reproduces how often:
Every time

Operating System and Brave Version(See the About Brave page in the main menu):
I have a system76 laptop with Pop! OS 22.04. with Brave v1.46.140. I think the linux kernel version is 6.0.6-76060006-generic.
Chrome v108.0.5359.98 (Official Build)(64-bit)
Firefox 107.0 (64-bit)

Additional Information:
I’ve been able to access my account with prior versions of Brave but unfortunately I don’t know what version number last worked.

Hello @danw, thank you for reaching us out. Have you tried clearing cookies and cache? Have you checked the block script option under shields > advanced controls is OFF Have you tried in a different profile or incognito/private window? Please let us know this information so we can further investigate the issue. Regards.

Thanks for your quick response!

  • block script is turned off.
  • Logged into t-mobile with my default profile and was able to do so. Then logged out.
  • Logged into t-mobile in a private window and that worked as well. Logged out,
  • Created a new profile and tried to log in but I got the same ‘Service Unavailable’ error I noted earlier.
    Thanks!

Hello again @danw, thank you for letting us know about this. If the issue persists or have more questions do not hesitate and reach us out again. Regards.

Dear all, [first - thanks for an excellent browser!]

I’m having exactly the same problem connecting to https://www.t-mobile.com/ , for at least a year already. I’m running Fedora 35,

uname -a
Linux zzzzzz 6.0.11-100.fc35.x86_64 #1 SMP PREEMPT_DYNAMIC Fri Dec 2 21:00:55 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

and the current version of Brave is

Version 1.46.134 Chromium: 108.0.5359.94 (Official Build) (64-bit)

I do have ‘block scripts’ set to OFF, and Firefox and Chrome browsers running on the same machine in their respective default configurations connect to TMobile w/o any problem.

The symptoms I’m experiencing do not depend on

  • whether tracking is allowed or not,
  • whether the 3rd party cookies are enabled or not
  • whether a regular, or a private, or a guest window is used

deleting all cookies doesn’t change anything

Another report on the subject claims that the problem is on the TMobile side:

, which is quite plausible, however a user might appreciate having a switch which could be used to get Brave behave the same way as Firefox/Chrome.

Does anyone know if such exists?

– many thanks, regards, Pavel Murat

I ran into this issue recently but logged in today with no issues. Whatever it was must’ve been fixed.

thanks - I realize that. I doubt the issue has been fixed - just reset the Brave configuration to the default, tried to login to my TMobile account and got the same failure…

It has to be some check on the Brave side - I think I see the initial handshaking succeeding and the connection breaking after that…

Hopfully, some of Brave people have TMobile and could give it a try…

I have the same issue here; however, I’m on macOS Ventura, and Safari allows me to log in, etc…
This is an issue with Brave/T-Mobile.
Go figure!

Hey everyone! First off, want to say we had someone share solution late last year. You can see what they said below:

You can see people kind of discuss this in other places as well, such as linked below.

While the below doesn’t say it still goes to show been an issue a while:

https://www.elevenforum.com/t/all-three-of-my-browsers-block-one-website.5868/

https://www.reddit.com/r/tmobile/comments/lm6zu9/anyone_recognize_f451_service_unavailable_message/

That said, if each of you would like to try some basic troubleshooting steps, we can make our way through to kind of check if anything else might be causing issues. Try each step independently. If it doesn’t fix the problem, then put settings back to normal (or go to your default profile) and then try the next step.

1. Turn off Shields.
This will just kind of help to figure out if Shields settings might be causing an issue. Especially will perhaps confirm if they require that tracking cookie as others mentioned in order to let you in. If it works here, then you’ll have to make your decision of whether you want to allow T-Mobile to have that access.

2. Open in a Private Window and try
The purpose of this is to see if extensions might be causing a conflict. Unless you’re changed settings to allow extensions to run in Private Window, this would run Brave without extensions. If it works here, then you know extension is likely what’s breaking things.

3. Try in Guest Window or Create a new profile (this is available Desktop only. Guest Window is temporary until window is closed, New Profile exists until deleted. Otherwise do the same thing)
This also is done to check extensions, but it goes one step further. Overall your browser goes back to default settings in the New Profile or Guest Window. So if it doesn’t work with Private Window but it works here, then likely is a setting you changed. The challenge, of course, is figuring out which.

4. Clear site settings
This is kind of a long shot. If this was the issue, should have seen resolved in new profile/guest window. However, sometimes it’s a random cookie or a toggle on Shields you may have persisted when it shouldn’t have. So clearing helps put all site settings back to default and can work. Easy way to access Site Settings if you’re unaware is to click on the lock icon in your address bar and then go to Site Settings from which you can Clear Data.

You can also go the more annoying route of brave://settings/privacyClear browsing data, choose All Time, and then make sure it’s clearing Cookies and other site data. This will log you out of everything. It’s more thorough but meh.