Brave not displaying certain web pages

bug
linux

#1

Failed Page: https://onlinebanking.tdbank.com
I have Brave Shields OFF

The page also fails on Android 7.1.2N2G47H w/Brave: 1.0.72, Chromium 71.0.3578.99
The page does not fail when using Firefox 64.0.1

Version 0.59.34 Chromium: 72.0.3626.81 (Official Build) (64-bit)
OS: Linux Mint 19.1 Cinnamon 4.0.9
Linux Kernel: 4.15.0-45-generic
Processor: AMD Athlon™ II X4 610e Processor × 4
Memory: 7.3 GiB


#2

@THX1138,
Im afk rn but am able to load the site on mobile. Does the site break after authenticating for you or does the page not display at all?


#3

I don’t even get to authenticate. The page does not display at all.


#4

Both Android and desktop versions display correctly ( MacOS and Windows).


I’m guessing this is a Linux specific issue. I’ll have to test on a VM on my end.
In the meantime cc @sriram for additional input.


#5

Dont this its an issue on any platform. I am able to open the site in Linux. Could be a cache issue. Could you try clearing browser cache and try again?


#6

Cleared cache: Advanced > All time > All items > Clear data
Tried page: https://onlinebanking.tdbank.com/
Set “Always allow Javascript”.

Same issue. Page not displayed. (View of console messages …)


#7

Whats the global cookie setting? Console errors seems like its not able to set/read cookies. If you have block all cookies then please change it to block 3rd party cookies and try again. I am able to load the site with default shields settings which is block 3rd party cookies


#8

It was already set to the configuration you suggest.


Also note that I tried the site with Shields OFF in one of the trials above. Same problem then also.


#9

Well this is really weird. Because when I try to load the site on beta channel, I see the login page and there no console errors. Does the site work on Chrome? Also could you update to 0.59.35 and check?


#10

I’m using Brave Version 0.59.35 Chromium: 72.0.3626.81 (Official Build) (64-bit)

The site works on a fresh install of Chrome 72.0.3626.96.


#11

Just tested on VM and page displays for me using Linux Mint Cinnamon as well: