Can't install Brave on lubuntu

I’ve been trying to install Brave on my Raspberry Pi 400 running lubuntu 20.04.2 LTS. Following guide on official Brave website. After I type in last step, I get this:
E: Unable to locate package brave-browser-beta
Is it possible to install Brave on lubuntu or not? Thank you for your help.

Try just “brave-browser”

If not, try following this,

I tried every one on that website, none is working.

Just looked some more. Appears there isn’t an official build or support for arm devices (Only 64 bit AMD/Intel).

You could try installing from source, however I don’t have experience doing that.

You probably tried this already, but does it work just doing it through the package managers instead of thru commands? Manjaro, Ubuntu 21 and A Ubuntu gaming version I have been able to install brave on using their package store managers, never thru command prompts.


Its possible, i just installed it today in a lubuntu machine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.