Can't disable Sync

Have Brave installed from AUR (Arch Linux) on my three laptops.

The first one has an “initial” config, copied from my Chromium.
Then, I’ve added another device by using a Sync Code from the first device - everything was good here.

Now, I’ve added a third device using the same code, but now it doesn’t sync anything, and the Sync options have the only " Manage your synced devices" option.

Then, I’m clicking on the “Leave Sync Chain” - but nothing happens. The browser still displays " Manage your synced devices" instead of a button to start a new chain.

Any cache? Or what else can prevent it do resetting?
Even if I’m doing a “Full reset” for all options - it doesn’t help and still displays “Manage your synced devices”.
And tried to disable/enable Sync V2 via brave://flags/ - no results.

Btw, if navigate to the “Manage your synced devices” - there are no other laptops listed: