Can't claim reward

Hello everyone,
When I do the claim reward captcha, I do as I have to, but It says “Hmmm, not quite…
Prove that you are human!”.
I can I solve that ? Thanks !


My issue →

Am experiencing same issue… Please help


I’ve had the issue since I started and even looking back on previous posts about this I have no found a proper fix. Nothing has been adjusted and I’ve tried several different monitors.

Same issue here. I’ve tried close to 50 times over the last 2 days.
No matter how quick I drag to the shape, it gives me an error.

I have the same issue. Windows 10 on a Surface 7 Pro.

I also have same issue here ,Kindly solve this issue .Thankyou.

The same problem. Unable to claim rewards. Stuck on Brave symbol. Please help!

Same here ! Stuck on “BRAVE REWARDS CLAIM” !And i can assure you i am a human being ! Untill you prove i’am not :slight_smile:

Fix here : Prove that human fails. It worked for me

Yes, the solution is to zoom out to 80%, it worked !

1 Like

I have the same issue too

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.