Cannot pass captcha verification to claim BAT

usually I am able to do the “verify you are human” triangle dragging things immediately but this this it refuses to work. I must have tried 50 times. I am using one desktop (laptop) and zoom is not the issue because I was at 100%. I am on a PC.

4 Likes

Same problem here on the main Brave browser using Windows 10, 64 bit. Beta, Nightly and android versions worked fine. But on the Brave Browser (v.1.30.87) keep getting “Hmmm, not quite”.

@steeven @Aa-ron ? :blush:

2 Likes

Here too, more of the same. I thought it was something that only happened to me, but I see it happens to many in the community. Hopefully they will give us an answer.

1 Like

Worked for me at 50% on the Rewards Settings page.
Windows 10.

1 Like

Same problem with me… Both from Rewards page and from new panel page

OK guys, found a cure on another thread in the forum that worked for me. Try downscaling the page with ctrl and - and then try claim rewards.

2 Likes

I’m having the same issue.

Hi everyone,

the solution posted by @Thrive has worked for me using 25% down zoom. I am on 4K screen resolution, 15.6’’ laptop - Windows 10

1 Like